aboutsummaryrefslogtreecommitdiffstats
path: root/net/dhcprelay
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-11-25 17:31:21 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-11-25 17:31:21 +0800
commit083ae520f82ac75f5585e9bd6fb150d0e3a5e81e (patch)
tree11feee2247b58c4f5f6fd660752bc0f74bf58c44 /net/dhcprelay
parentfb11edfff2136b77c781d26c439382e312f8e558 (diff)
downloadfreebsd-ports-gnome-083ae520f82ac75f5585e9bd6fb150d0e3a5e81e.tar.gz
freebsd-ports-gnome-083ae520f82ac75f5585e9bd6fb150d0e3a5e81e.tar.zst
freebsd-ports-gnome-083ae520f82ac75f5585e9bd6fb150d0e3a5e81e.zip
- Add LICENSE
- Respect CFLAGS/LDFLAGS
Diffstat (limited to 'net/dhcprelay')
-rw-r--r--net/dhcprelay/Makefile5
-rw-r--r--net/dhcprelay/files/patch-Makefile4
2 files changed, 6 insertions, 3 deletions
diff --git a/net/dhcprelay/Makefile b/net/dhcprelay/Makefile
index 3860d25dcad9..fbad50bb9348 100644
--- a/net/dhcprelay/Makefile
+++ b/net/dhcprelay/Makefile
@@ -10,11 +10,14 @@ MASTER_SITES= http://www.mavetju.org/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= Lightweight DHCP Relay Agent with GIF tunnel support
+LICENSE= NONE
+
LIB_DEPENDS= libdnet.so:net/libdnet
-PLIST_FILES= bin/dhcprelay
USE_RC_SUBR= ${PORTNAME}
+PLIST_FILES= bin/dhcprelay
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dhcprelay ${STAGEDIR}${PREFIX}/bin
diff --git a/net/dhcprelay/files/patch-Makefile b/net/dhcprelay/files/patch-Makefile
index 3337308401a2..624a4b2196e7 100644
--- a/net/dhcprelay/files/patch-Makefile
+++ b/net/dhcprelay/files/patch-Makefile
@@ -5,11 +5,11 @@
+
dhcprelay: dhcprelay.o
- gcc -g -o $@ -Wall -L/usr/local/lib -lpcap -ldnet $>
-+ ${CC} -g -o $@ -Wall -L${LOCALBASE}/lib -lpcap -ldnet $>
++ ${CC} ${LDFLAGS} -o $@ -Wall -L${LOCALBASE}/lib -lpcap -ldnet $>
dhcprelay.o: dhcprelay.c
- gcc -g -c -o $@ -Wall -I/usr/local/include $<
-+ ${CC} -g -c -o $@ -Wall -I${LOCALBASE}/include $<
++ ${CC} ${CFLAGS} -c -o $@ -Wall -I${LOCALBASE}/include $<
clean:
rm -f dhcprelay.o dhcprelay dhcprelay.core