aboutsummaryrefslogtreecommitdiffstats
path: root/net/dhid/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2001-02-26 12:09:51 +0800
committersteve <steve@FreeBSD.org>2001-02-26 12:09:51 +0800
commit69f8e8ba755e17163c12e673034c8424c506fe41 (patch)
tree4bbd2f2ec44bf90a631f42a0cc79036b16e51298 /net/dhid/Makefile
parent215e1ec8a0ddb72db54589fde3d1d09153f3e362 (diff)
downloadfreebsd-ports-gnome-69f8e8ba755e17163c12e673034c8424c506fe41.tar.gz
freebsd-ports-gnome-69f8e8ba755e17163c12e673034c8424c506fe41.tar.zst
freebsd-ports-gnome-69f8e8ba755e17163c12e673034c8424c506fe41.zip
Update to version 4.0.2.
PR: 24326 Submitted by: George Reid <greid@ukug.uk.freebsd.org>
Diffstat (limited to 'net/dhid/Makefile')
-rw-r--r--net/dhid/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/net/dhid/Makefile b/net/dhid/Makefile
index e01835a2e849..abe318814d5d 100644
--- a/net/dhid/Makefile
+++ b/net/dhid/Makefile
@@ -6,12 +6,16 @@
#
PORTNAME= dhid
-PORTVERSION= 3.1
+PORTVERSION= 4.0.2
CATEGORIES= net
MASTER_SITES= ftp://ftp.dhis.org/pub/dhis/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ ${PORTNAME}-3.1${EXTRACT_SUFX}
MAINTAINER= oryx@ungulate.net
+OLDWRKSRC= ${WRKDIR}/${PORTNAME}-3.1
+
MAN8= dhid.8
post-patch:
@@ -20,18 +24,14 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dhid ${PREFIX}/sbin
- ${INSTALL_MAN} ${WRKSRC}/dhid.8 ${PREFIX}/man/man8
- ${INSTALL} ${COPY} -o root -g wheel -m 600 ${WRKSRC}/dhid.conf ${PREFIX}/etc/dhid.conf.sample
+ ${INSTALL_MAN} ${OLDWRKSRC}/dhid.8 ${PREFIX}/man/man8
+ ${INSTALL} ${COPY} -o root -g wheel -m 600 ${OLDWRKSRC}/dhid.conf ${PREFIX}/etc/dhid.conf.sample
post-install:
@if [ ! -f ${PREFIX}/etc/rc.d/dhid.sh ]; then \
${ECHO} "===> Installing ${PREFIX}/etc/rc.d/dhid.sh startup file."; \
${INSTALL_SCRIPT} -m 751 ${FILESDIR}/dhid.sh ${PREFIX}/etc/rc.d/dhid.sh; \
fi;
- @${ECHO} "--------------------------------------------------------------------------"
- @${ECHO} "Before dhid can run, you will need to register with a DHIS provider."
- @${ECHO} "See http://www.dhis.org/dhis/services/ for a list of providers."
- @${ECHO} "Enter the DHIS account information into the ${PREFIX}/etc/dhid.conf file."
- @${ECHO} "--------------------------------------------------------------------------"
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>