aboutsummaryrefslogtreecommitdiffstats
path: root/net/dictd/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-01-25 23:55:46 +0800
committerijliao <ijliao@FreeBSD.org>2001-01-25 23:55:46 +0800
commit40684706f879301962e696dbb4373c3641a40eb0 (patch)
tree21fc0c8217605046dc1f729db8807c6b4c6f3591 /net/dictd/Makefile
parent541a7f5b9349ef66092d8752788d0a2ed3610b27 (diff)
downloadfreebsd-ports-gnome-40684706f879301962e696dbb4373c3641a40eb0.tar.gz
freebsd-ports-gnome-40684706f879301962e696dbb4373c3641a40eb0.tar.zst
freebsd-ports-gnome-40684706f879301962e696dbb4373c3641a40eb0.zip
add dictd, dict protocol (RFC 2229) server
Diffstat (limited to 'net/dictd/Makefile')
-rw-r--r--net/dictd/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/net/dictd/Makefile b/net/dictd/Makefile
new file mode 100644
index 000000000000..b4df434eb0e2
--- /dev/null
+++ b/net/dictd/Makefile
@@ -0,0 +1,44 @@
+# ex:ts=8
+# New ports collection makefile for: dictd
+# Date created: Jan 23, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dictd
+PORTVERSION= 1.5.5
+CATEGORIES= net textproc
+MASTER_SITES= ftp://ftp.dict.org/pub/dict/
+
+MAINTAINER= ijliao@FreeBSD.org
+
+MAN1= dictzip.1
+MAN8= dictd.8
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= "--prefix=${PREFIX} --with-cflags=${CFLAGS} --with-etcdir=${PREFIX}/etc"
+USE_GMAKE= yes
+
+ALL_TARGET= dictd dictzip
+INSTALL_TARGET= install.dictd install.dictzip
+
+post-patch:
+.for i in dict.1 dictd.8
+ @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/$i
+.endfor
+ @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${PKGMESSAGE}
+.for i in dictd.conf example.conf
+ @${PERL} -pi -e "s|/usr|${PREFIX}|g" ${WRKSRC}/$i
+.endfor
+
+post-install:
+ @${MKDIR} ${PREFIX}/share/${PORTNAME}
+.for i in example.conf example.dictrc example.site example2.conf example3.conf
+ ${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/share/${PORTNAME}
+.endfor
+ @${SED} "s|%%PREFIX%%|${PREFIX}|g" < ${FILESDIR}/dictd.sh > ${PREFIX}/etc/rc.d/dictd.sh
+ @${CHMOD} +x ${PREFIX}/etc/rc.d/dictd.sh
+ @${SED} "s|%%PREFIX%%|${PREFIX}|g" < ${PKGMESSAGE}
+
+.include <bsd.port.mk>