aboutsummaryrefslogtreecommitdiffstats
path: root/net/dictd
diff options
context:
space:
mode:
authordd <dd@FreeBSD.org>2002-04-12 10:25:10 +0800
committerdd <dd@FreeBSD.org>2002-04-12 10:25:10 +0800
commit487c5c7927e9afe14b7b00c1830f84f40f7c9746 (patch)
tree16944592b17a97d262adf78d3ac39bc01ab770a5 /net/dictd
parentf67528dd32f695ba19b53fdcfd9e6b803bce578f (diff)
downloadfreebsd-ports-gnome-487c5c7927e9afe14b7b00c1830f84f40f7c9746.tar.gz
freebsd-ports-gnome-487c5c7927e9afe14b7b00c1830f84f40f7c9746.tar.zst
freebsd-ports-gnome-487c5c7927e9afe14b7b00c1830f84f40f7c9746.zip
The regexp used to change T_USER to T_USERNAME only works if the
symbol is preceded by whitespace. However, on line 64 of servscan.l, the symbol is preceded by a parenthesis, so it is left alone. On i386, T_USER is defined, so the build proceeds, but there may still be adverse side effects due to that routine returning the wrong thing in some cases. The bandaid is to fix the regexp to catch the case where T_USER is used after a parenthesis--this is what's being committed. The real fix is either to make the author use T_USERNAME for us, or, preferably, don't define T_USER when sys/param.h is included since T_USER is in the application namespace. Approved by: maintainer timeout
Diffstat (limited to 'net/dictd')
-rw-r--r--net/dictd/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/net/dictd/Makefile b/net/dictd/Makefile
index 71ac387c32da..d75ffd806a50 100644
--- a/net/dictd/Makefile
+++ b/net/dictd/Makefile
@@ -34,7 +34,7 @@ post-patch:
@${PERL} -pi -e "s|/usr|${PREFIX}|g" ${WRKSRC}/$i
.endfor
@${PERL} -pi -e "s|%%CFLAGS%%|${CFLAGS}|g" ${WRKSRC}/zlib/Makefile
- @${PERL} -pi -e "s|[\ \t]T_USER| T_USERNAME|g" ${WRKSRC}/*.[chly]
+ @${PERL} -pi -e "s|([\ \t(])T_USER|\1T_USERNAME|g" ${WRKSRC}/*.[chly]
post-install:
@${MKDIR} ${DATADIR}