aboutsummaryrefslogtreecommitdiffstats
path: root/net/ekiga
diff options
context:
space:
mode:
authorlawrance <lawrance@FreeBSD.org>2005-12-17 17:51:15 +0800
committerlawrance <lawrance@FreeBSD.org>2005-12-17 17:51:15 +0800
commit705a35c15f6afa479c4dcc8b197050e31d36c68e (patch)
tree455236e37ee0be64aa9fa8b93484c482c64bf97d /net/ekiga
parent6d9b2bb3ee4361c3202a0afc65c056b3e14b82b6 (diff)
downloadfreebsd-ports-gnome-705a35c15f6afa479c4dcc8b197050e31d36c68e.tar.gz
freebsd-ports-gnome-705a35c15f6afa479c4dcc8b197050e31d36c68e.tar.zst
freebsd-ports-gnome-705a35c15f6afa479c4dcc8b197050e31d36c68e.zip
Use a more accurate method of determining WRKSRC paths for pwlib and openh323.
PR: ports/77857 Submitted by: Sergei Kolobov <sergei@FreeBSD.org> Approved by: kwm (maintainer, timeout 9 months)
Diffstat (limited to 'net/ekiga')
-rw-r--r--net/ekiga/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/net/ekiga/Makefile b/net/ekiga/Makefile
index edef926d0643..8caed373d57b 100644
--- a/net/ekiga/Makefile
+++ b/net/ekiga/Makefile
@@ -33,22 +33,26 @@ CONFIGURE_TARGET=
GNU_CONFIGURE= YES
CONFIGURE_ENV= OSTYPE=${OPSYS} \
LIBS="-L${PREFIX}/lib -L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
- PTLIBDIR=${WRKDIRPREFIX}${.CURDIR}/../../devel/pwlib/work/pwlib \
- OPENH323DIR=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/openh323 \
+ PTLIBDIR=${PWLIBDIR} \
+ OPENH323DIR=${OPENH323DIR} \
SDL_CONFIG=${LOCALBASE}/bin/sdl11-config \
CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}"
-CONFIGURE_ARGS= --with-ptlib-includes=${WRKDIRPREFIX}${.CURDIR}/../../devel/pwlib/work/pwlib/include/ptlib \
- --with-ptlib-libs=${WRKDIRPREFIX}${.CURDIR}/../../devel/pwlib/work/pwlib/lib \
- --with-openh323-includes=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/openh323/include \
- --with-openh323-libs=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/openh323/lib \
- --with-ldap-includes=${LOCALBASE}/include \
- --with-openldap-libs=${LOCALBASE}/lib
+CONFIGURE_ARGS= --with-ptlib-includes=${PWLIBDIR}/include/ptlib \
+ --with-ptlib-libs=${PWLIBDIR}/lib \
+ --with-openh323-includes=${OPENH323DIR}/include \
+ --with-openh323-libs=${OPENH323DIR}/lib \
+ --with-ldap-includes=${LOCALBASE}/include \
+ --with-openldap-libs=${LOCALBASE}/lib
+
GCONF_SCHEMAS= gnomemeeting.schemas
MAN1= gnomemeeting.1
.include <bsd.port.pre.mk>
+PWLIBDIR!= cd ${PORTSDIR}/devel/pwlib && make -V WRKSRC
+OPENH323DIR!= cd ${PORTSDIR}/net/openh323 && make -V WRKSRC
+
.if ${ARCH} != "i386"
BROKEN= "Configure fails on !i386"
.endif