aboutsummaryrefslogtreecommitdiffstats
path: root/net/ethereal
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-05-12 01:37:34 +0800
committermarcus <marcus@FreeBSD.org>2005-05-12 01:37:34 +0800
commit06a7a5c87e0511cecd6cdcee4c120e5656c579ef (patch)
treecc91ce5aab1823137bab922104c415f2600c57be /net/ethereal
parentdf37bee538e53f02f4625aba690781784a2188da (diff)
downloadfreebsd-ports-gnome-06a7a5c87e0511cecd6cdcee4c120e5656c579ef.tar.gz
freebsd-ports-gnome-06a7a5c87e0511cecd6cdcee4c120e5656c579ef.tar.zst
freebsd-ports-gnome-06a7a5c87e0511cecd6cdcee4c120e5656c579ef.zip
* Add a dependency on gnometarget
* Add a dependency on libiconv to fix the gtk12/glib12 build [1] Reported by: pointyhat via kris [1]
Diffstat (limited to 'net/ethereal')
-rw-r--r--net/ethereal/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/net/ethereal/Makefile b/net/ethereal/Makefile
index b559b42b8cb9..ba22f0bcaf54 100644
--- a/net/ethereal/Makefile
+++ b/net/ethereal/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ethereal
PORTVERSION= 0.10.11
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.ethereal.com/pub/ethereal/all-versions/ \
ftp://gd.tuwien.ac.at/infosys/security/ethereal/all-versions/ \
@@ -17,8 +18,11 @@ MASTER_SITES= ftp://ftp.ethereal.com/pub/ethereal/all-versions/ \
MAINTAINER= marcus@FreeBSD.org
COMMENT?= A powerful network analyzer/capture tool
+LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
+
USE_PERL5_BUILD=yes
USE_BZIP2= yes
+USE_GNOME= gnometarget
WANT_GNOME= yes
CONFIGURE_ARGS+= --program-transform-name=""
INSTALLS_SHLIB= yes
@@ -43,14 +47,14 @@ USE_X_PREFIX= yes
MAN1+= ethereal.1
PLIST_SUB+= ETHEREAL=bin/ethereal
.if defined(WITHOUT_GTK2)
-USE_GNOME= gtk12
+USE_GNOME+= gtk12
CONFIGURE_ARGS+= --disable-gtk2
.else
-USE_GNOME= gtk20
+USE_GNOME+= gtk20
.endif
.else
PLIST_SUB+= ETHEREAL="@comment ethereal not built"
-USE_GNOME= glib12
+USE_GNOME+= glib12
CONFIGURE_ARGS+= --enable-ethereal=no \
--disable-gtktest \
--with-gtk-prefix=/nonexistent \