aboutsummaryrefslogtreecommitdiffstats
path: root/net/eudc-emacs20/Makefile
diff options
context:
space:
mode:
authorsada <sada@FreeBSD.org>2001-09-18 02:49:50 +0800
committersada <sada@FreeBSD.org>2001-09-18 02:49:50 +0800
commitb416a22f6cfc4164b7d607284d5d8ee912cccd63 (patch)
tree428603071c69991953db4fed8975091284e15d31 /net/eudc-emacs20/Makefile
parent3f4ffff96b114333af00c98ee270871d67ab45eb (diff)
downloadfreebsd-ports-gnome-b416a22f6cfc4164b7d607284d5d8ee912cccd63.tar.gz
freebsd-ports-gnome-b416a22f6cfc4164b7d607284d5d8ee912cccd63.tar.zst
freebsd-ports-gnome-b416a22f6cfc4164b7d607284d5d8ee912cccd63.zip
New port: eudc-emacs20
EUDC is a user-friendly e-lisp client interface to directory servers running various protocols: 1) LDAP: Lightweight Directory Protocol 2) CCSO: white pages directory system also known as PH/QI (from its standard client and server names). 3) BBDB: Big Brother's Insiduous Database (BBDB is a local directory database) EUDC lets you query your corporate directory server for information such as phone numbers and office locations. It lets you also query public servers such as Four11 or BigFoot to complete email addresses directly from the server while composing email messages in VM, Gnus, Rmail,... WWW: http://lspwww.epfl.ch/~figueire/Software/eudc/ PR: ports/24991 Submitted by: Ilya Martynov <ilya@martynov.org>
Diffstat (limited to 'net/eudc-emacs20/Makefile')
-rw-r--r--net/eudc-emacs20/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/net/eudc-emacs20/Makefile b/net/eudc-emacs20/Makefile
new file mode 100644
index 000000000000..3dce13d594a0
--- /dev/null
+++ b/net/eudc-emacs20/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: eudc-emacs20
+# Date created: 8 February 2001
+# Whom: ilya
+#
+# $FreeBSD$
+#
+
+PORTNAME= eudc
+PORTVERSION= 1.30b
+CATEGORIES= net mail elisp
+MASTER_SITES= http://lspwww.epfl.ch/~figueire/Software/eudc/
+PKGNAMESUFFIX= -${EMACS_PORT_NAME}
+
+MAINTAINER= ilya@martynov.org
+
+RUN_DEPENDS= ldapsearch:${PORTSDIR}/net/openldap
+
+EMACS_PORT_NAME?=emacs20
+
+USE_GMAKE= yes
+MAKEFILE= GNUmakefile
+
+INFODIR= ${PREFIX}/info
+
+PORTDOCDIR= share/doc/${PORTNAME}-${EMACS_PORT_NAME}
+DOCS= COPYRIGHT ChangeLog INSTALL NEWS README
+SOURCES= eudc-autoloads.el eudc-bob.el eudc-export.el \
+ eudc-hotlist.el eudc-vars.el eudc.el \
+ eudcb-bbdb.el eudcb-ldap.el eudcb-ph.el ldap.el
+ELCS= ${SOURCES:S/.el/.elc/g}
+INFOS= eudc.info
+
+PLIST_SUB= EMACS_PORT_NAME=${EMACS_PORT_NAME} \
+ INFODIR=${INFODIR:S/${PREFIX}\///} \
+ EMACS_SITE_LISPDIR=${EMACS_SITE_LISPDIR}
+
+INSTALL_TARGET=
+lispdir= ${PREFIX}/${EMACS_SITE_LISPDIR}/eudc
+post-install:
+ ${MKDIR} ${lispdir};
+.for i in ${SOURCES} ${ELCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${lispdir}
+.endfor
+.for i in ${INFOS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${INFODIR}
+ install-info ${INFODIR}/eudc.info ${INFODIR}/dir
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/${PORTDOCDIR}
+.for i in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/${PORTDOCDIR}
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>