aboutsummaryrefslogtreecommitdiffstats
path: root/net/foreman-proxy
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-09-09 01:02:12 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-09-09 01:02:12 +0800
commit989bf2785a42af9db6038a89c3fa95193d20490c (patch)
tree1ebb96ec15a26a26de6ca0d04c7d17bffa19b7c5 /net/foreman-proxy
parent20e8637921154df918cfd290fef10ea9e3f98d23 (diff)
downloadfreebsd-ports-gnome-989bf2785a42af9db6038a89c3fa95193d20490c.tar.gz
freebsd-ports-gnome-989bf2785a42af9db6038a89c3fa95193d20490c.tar.zst
freebsd-ports-gnome-989bf2785a42af9db6038a89c3fa95193d20490c.zip
- Fix dependency on sysutils/puppet which was split into sysutils/puppet{37,38,4} ports
- Provide option to choose actual puppet version PR: 207326 Submitted by: Karli.Sjoberg@slu.se Approved by: maintainer timeout (ruby, 6 months)
Diffstat (limited to 'net/foreman-proxy')
-rw-r--r--net/foreman-proxy/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/net/foreman-proxy/Makefile b/net/foreman-proxy/Makefile
index 877b0dd33586..8628bb0cb52c 100644
--- a/net/foreman-proxy/Makefile
+++ b/net/foreman-proxy/Makefile
@@ -3,6 +3,7 @@
PORTNAME= foreman-proxy
PORTVERSION= 1.10.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://downloads.theforeman.org/foreman-proxy/
@@ -10,6 +11,7 @@ MAINTAINER= ruby@FreeBSD.org
COMMENT= Foreman Proxy Agent
LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= rubygem-bundler_ext>=0.4:sysutils/rubygem-bundler_ext \
rubygem-json>=1.8.1:devel/rubygem-json \
@@ -17,9 +19,12 @@ RUN_DEPENDS= rubygem-bundler_ext>=0.4:sysutils/rubygem-bundler_ext \
rubygem-sinatra>=1.4.3:www/rubygem-sinatra \
${LOCALBASE}/bin/wget:ftp/wget
-OPTIONS_DEFINE= BMC PUPPET
+OPTIONS_DEFINE= BMC
+OPTIONS_RADIO= PUPPET
+OPTIONS_RADIO_PUPPET= PUPPET3 PUPPET4
BMC_DESC= Depend on rubyipmi for BMC support
-PUPPET_DESC= Depend on Puppet
+PUPPET3_DESC= Depend on Puppet 3.8
+PUPPET4_DESC= Depend on Puppet 4
USES= tar:bzip2
USE_RUBY= yes
@@ -44,7 +49,9 @@ SUB_LIST= RUBY="${RUBY}" \
PLIST_SUB= ${SUB_LIST} MKDIR="${MKDIR}"
BMC_RUN_DEPENDS= rubygem-rubyipmi>=0.10.0:sysutils/rubygem-rubyipmi
-PUPPET_RUN_DEPENDS= puppet:sysutils/puppet \
+PUPPET3_RUN_DEPENDS= puppet:sysutils/puppet38 \
+ rubygem-ruby-augeas>=0.5:textproc/rubygem-ruby-augeas
+PUPPET4_RUN_DEPENDS= puppet:sysutils/puppet4 \
rubygem-ruby-augeas>=0.5:textproc/rubygem-ruby-augeas
post-patch: