aboutsummaryrefslogtreecommitdiffstats
path: root/net/freenet6/Makefile
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2001-11-21 04:45:55 +0800
committerpetef <petef@FreeBSD.org>2001-11-21 04:45:55 +0800
commit3e15c4c54231c5a86613a7c62273f4155bfc1940 (patch)
treefed2886c6754959b36d5824782d6e5feccea0655 /net/freenet6/Makefile
parentdc728f4268f7af0e06fc32f229e5d84c600e327d (diff)
downloadfreebsd-ports-gnome-3e15c4c54231c5a86613a7c62273f4155bfc1940.tar.gz
freebsd-ports-gnome-3e15c4c54231c5a86613a7c62273f4155bfc1940.tar.zst
freebsd-ports-gnome-3e15c4c54231c5a86613a7c62273f4155bfc1940.zip
- don't try to modify things outside of ${WRKDIR}
- cleanup pkg-message handling: we don't need a base pkg-message: we generate ${WRKSRC}/pkg-message from ${FILESDIR}/pkg-message.in - pkg-message -> ${PKGMESSAGE} - use a different example host to ping6 in pkg-message.in PR: 31921 Submitted by: maintainer
Diffstat (limited to 'net/freenet6/Makefile')
-rw-r--r--net/freenet6/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/net/freenet6/Makefile b/net/freenet6/Makefile
index 9602433bebad..53d18a168c55 100644
--- a/net/freenet6/Makefile
+++ b/net/freenet6/Makefile
@@ -16,6 +16,8 @@ MAINTAINER= edwin@mavetju.org
MAN8= tspc.8
MAN5= tspc.conf.5
+PKGMESSAGE= ${WRKSRC}/pkg-message
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 400000
@@ -50,17 +52,17 @@ do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/template/freebsd4.sh ${PREFIX}/bin/tspc-freebsd4.sh
@${INSTALL_MAN} ${WRKSRC}/man/man8/tspc.8 ${PREFIX}/man/man8
@${INSTALL_MAN} ${WRKSRC}/man/man5/tspc.conf.5 ${PREFIX}/man/man5
- @${INSTALL_SCRIPT} ${FILESDIR}/freenet6.sh ${PREFIX}/etc/rc.d/
+ @${INSTALL_SCRIPT} ${WRKSRC}/freenet6.sh ${PREFIX}/etc/rc.d/
post-install:
- @${CAT} pkg-message
+ @${CAT} ${PKGMESSAGE}
post-patch:
@${MV} ${WRKSRC}/src/tspc.c ${WRKSRC}/src/tspc.c.orig
@${SED} -e "s|tspc.conf|${PREFIX}/etc/tspc.conf|" < ${WRKSRC}/src/tspc.c.orig > ${WRKSRC}/src/tspc.c
- @${SED} -e "s|@@PREFIX@@|${PREFIX}|g" < ${FILESDIR}/freenet6.sh.in > ${FILESDIR}/freenet6.sh
- @${SED} -e "s|@@PREFIX@@|${PREFIX}|g" < ${FILESDIR}/pkg-message.in > pkg-message
+ @${SED} -e "s|@@PREFIX@@|${PREFIX}|g" < ${FILESDIR}/freenet6.sh.in > ${WRKSRC}/freenet6.sh
+ @${SED} -e "s|@@PREFIX@@|${PREFIX}|g" < ${FILESDIR}/pkg-message.in > ${WRKSRC}/pkg-message
@${MV} ${WRKSRC}/man/man8/tspc.8 ${WRKSRC}/man/man8/tspc.8.orig
@${SED} -e "s|@@PREFIX@@|${PREFIX}|g" < ${WRKSRC}/man/man8/tspc.8.orig > ${WRKSRC}/man/man8/tspc.8
@@ -68,7 +70,4 @@ post-patch:
@${MV} ${WRKSRC}/man/man5/tspc.conf.5 ${WRKSRC}/man/man5/tspc.conf.5.orig
@${SED} -e "s|@@PREFIX@@|${PREFIX}|g" < ${WRKSRC}/man/man5/tspc.conf.5.orig > ${WRKSRC}/man/man5/tspc.conf.5
-post-clean:
- @${RM} -f ${FILESDIR}/freenet6.sh
-
.include <bsd.port.post.mk>