aboutsummaryrefslogtreecommitdiffstats
path: root/net/freeradius/Makefile
diff options
context:
space:
mode:
authorbrian <brian@FreeBSD.org>2002-05-11 02:59:23 +0800
committerbrian <brian@FreeBSD.org>2002-05-11 02:59:23 +0800
commitdb0f97dae8057cb99f4574ff5378e6688e268922 (patch)
tree5c2c608a4db4d9261a3dcb8e7288e29735e7ef4e /net/freeradius/Makefile
parent6a3fde5e2059b5a8ae6594dab65881cc7ddd5bbe (diff)
downloadfreebsd-ports-gnome-db0f97dae8057cb99f4574ff5378e6688e268922.tar.gz
freebsd-ports-gnome-db0f97dae8057cb99f4574ff5378e6688e268922.tar.zst
freebsd-ports-gnome-db0f97dae8057cb99f4574ff5378e6688e268922.zip
Add freeradius, a RADIUS daemon implementation compatible with
livingston radiusd-2.01. This RADIUS implementation implements MS-CHAP authentication whereas most or all of the others don't. Forced into it by: wollman (after removing freeradius-devel)
Diffstat (limited to 'net/freeradius/Makefile')
-rw-r--r--net/freeradius/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/net/freeradius/Makefile b/net/freeradius/Makefile
new file mode 100644
index 000000000000..2f79ca6183a6
--- /dev/null
+++ b/net/freeradius/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: freeradius
+# Date created: May 9 2002
+# Whom: Brian Somers <brian@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= freeradius
+PORTVERSION= 0.5
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.freeradius.org/pub/radius/ \
+ ftp://ftp.Awfulhak.org/pub/radius/
+
+MAINTAINER= brian@FreeBSD.org
+
+LIB_DEPENDS= gdbm.2:${PORTSDIR}/databases/gdbm
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --quiet --with-logdir=/var/log
+
+MAN1= radclient.1 radlast.1 radtest.1 raduse.1 radwho.1 radzap.1
+MAN5= acct_users.5 clients.5 dictionary.5 naslist.5 radiusd.conf.5 \
+ users.5
+MAN8= builddbm.8 radiusd.8 radwatch.8
+
+RADDB= acct_users attrs clients clients.conf dictionary \
+ dictionary.acc dictionary.aptis dictionary.ascend \
+ dictionary.bay dictionary.cisco dictionary.compat \
+ dictionary.erx dictionary.foundry dictionary.freeradius \
+ dictionary.livingston dictionary.microsoft dictionary.nomadix \
+ dictionary.quintum dictionary.redback dictionary.shasta \
+ dictionary.shiva dictionary.tunnel dictionary.usr \
+ dictionary.versanet hints huntgroups ldap.attrmap naslist \
+ naspasswd postgresql.conf proxy.conf radiusd.conf realms \
+ snmp.conf sql.conf users x99.conf
+
+post-install:
+.for db in ${RADDB}
+ ${INSTALL_DATA} ${WRKSRC}/raddb/${db} ${PREFIX}/etc/raddb/${db}.sample
+.endfor
+ ${INSTALL_SCRIPT} ${FILESDIR}/radiusd.sh ${PREFIX}/etc/rc.d/radiusd.sh
+
+.include <bsd.port.mk>