aboutsummaryrefslogtreecommitdiffstats
path: root/net/freeradius2/Makefile
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2009-09-10 01:02:31 +0800
committerwxs <wxs@FreeBSD.org>2009-09-10 01:02:31 +0800
commit7a33497c618e8d8b1de27ee8226b2beef6c01108 (patch)
tree839979648de7343a1c2c119fd93815b6d9833235 /net/freeradius2/Makefile
parent488911e546935e13b25a949b5466409742b7aee6 (diff)
downloadfreebsd-ports-gnome-7a33497c618e8d8b1de27ee8226b2beef6c01108.tar.gz
freebsd-ports-gnome-7a33497c618e8d8b1de27ee8226b2beef6c01108.tar.zst
freebsd-ports-gnome-7a33497c618e8d8b1de27ee8226b2beef6c01108.zip
- Add support for Oracle and debugging options (both off by default).
PR: ports/137425 Submitted by: Ryan Steinmetz <rpsfa@rit.edu> Approved by: maintainer timeout
Diffstat (limited to 'net/freeradius2/Makefile')
-rw-r--r--net/freeradius2/Makefile20
1 files changed, 19 insertions, 1 deletions
diff --git a/net/freeradius2/Makefile b/net/freeradius2/Makefile
index 47021bd2a064..4b93b3e3166b 100644
--- a/net/freeradius2/Makefile
+++ b/net/freeradius2/Makefile
@@ -51,6 +51,8 @@ OPTIONS= USER "Run as user freeradius, group freeradius" on \
FIREBIRD "With Firebird database support (EXPERIMENTAL)" off \
PERL "With Perl support" on \
PYTHON "With Python support" on \
+ OCI8 "With Oracle support (currently experimental)" off \
+ DEVELOPER "With developer support" off \
RUBY "With Ruby support (EXPERIMENTAL)" off \
DHCP "With DHCP support (EXPERIMENTAL)" off \
EXPERIMENTAL "Build experimental modules" off
@@ -201,6 +203,23 @@ PLIST_SUB+= SMB="@comment "
WITH_EXPERIMENTAL= yes
.endif
+.ifdef(WITH_DEVELOPER)
+CONFIGURE_ARGS+= --enable-developer
+.endif
+
+# Oracle support is experimental under FreeBSD
+.ifdef(WITH_OCI8)
+EXTRA_PATCHES+= files/extra-patch-exec.c
+CONFIGURE_ENV= ORACLE_HOME="${ORACLE_HOME}"
+ORACLE_HOME?= ${LOCALBASE}/oracle8-client
+BUILD_DEPENDS+= ${ORACLE_HOME}/lib/libclntst8.a:${PORTSDIR}/databases/oracle8-client
+CONFIGURE_ARGS+=--with-oracle-home-dir=${ORACLE_HOME}/rdbms/demo
+PLIST_SUB+= OCI8=""
+.else
+CONFIGURE_ARGS+=--without-rlm_sql_oracle
+PLIST_SUB+= OCI8="@comment "
+.endif
+
.ifdef(WITH_EXPERIMENTAL)
CONFIGURE_ARGS+=--with-experimental-modules
PLIST_SUB+= EXPM=""
@@ -255,7 +274,6 @@ CONFIGURE_ARGS+=--without-rlm_eap_ikev2 \
--without-rlm_opendirectory \
--without-rlm_sql_db2 \
--without-rlm_sql_iodbc \
- --without-rlm_sql_oracle \
--without-rlm_sql_sqlite \
--without-rlm_sql_sybase \
--with-vmps