aboutsummaryrefslogtreecommitdiffstats
path: root/net/geoipupdate
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-08-27 23:53:24 +0800
committeradamw <adamw@FreeBSD.org>2014-08-27 23:53:24 +0800
commitc79f27f5aaf56574620362102798e258be5d6102 (patch)
treec8ca3994db53f4b69919f7696df6d70b9b43d479 /net/geoipupdate
parent8838fc810088015ce4142b76dbd540a831589875 (diff)
downloadfreebsd-ports-gnome-c79f27f5aaf56574620362102798e258be5d6102.tar.gz
freebsd-ports-gnome-c79f27f5aaf56574620362102798e258be5d6102.tar.zst
freebsd-ports-gnome-c79f27f5aaf56574620362102798e258be5d6102.zip
- Update GeoIP to 1.6.2 and switch to its new github location.
- Add net/geoipupdate, the formal tool to fetch updates. It is for paid subscribers. People using the free version should continue using the geoipupdate.sh script in net/GeoIP. This program is used to fetch the GeoIP2 and GeoIP databases. It requires an active GeoIP subscription. Please see https://www.maxmind.com/en/geolocation_landing for details about obtaining a subscription. If you wish to install the free versions of the GeoIP databases, please use the geoipudate.sh script provided in net/GeoIP. WWW: https://github.com/maxmind/geoipupdate
Diffstat (limited to 'net/geoipupdate')
-rw-r--r--net/geoipupdate/Makefile37
-rw-r--r--net/geoipupdate/distinfo2
-rw-r--r--net/geoipupdate/pkg-descr10
-rw-r--r--net/geoipupdate/pkg-plist4
4 files changed, 53 insertions, 0 deletions
diff --git a/net/geoipupdate/Makefile b/net/geoipupdate/Makefile
new file mode 100644
index 000000000000..bcc0c23d7e6c
--- /dev/null
+++ b/net/geoipupdate/Makefile
@@ -0,0 +1,37 @@
+# Created by: adamw
+# $FreeBSD$
+
+PORTNAME= geoipupdate
+PORTVERSION= 2.0.2
+CATEGORIES= net geography
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Fetch the latest copies of the paid GeoIP database
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+
+USE_GITHUB= yes
+GH_ACCOUNT= maxmind
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= 929d6a7
+
+USES= libtool pathfix
+USE_AUTOTOOLS= aclocal automake autoconf libtoolize
+AUTOMAKE_ARGS= --add-missing
+PATHFIX_MAKEFILEIN= Makefile.am
+GNU_CONFIGURE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+post-extract:
+ @${MV} ${WRKSRC}/conf/GeoIP.conf.default ${WRKSRC}/conf/GeoIP.conf.sample
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^DEFAULT_CONFIG_FILE =/s/$$/.sample/' \
+ -e 's/.default/.sample/' \
+ ${WRKSRC}/conf/Makefile.am
+
+.include <bsd.port.mk>
diff --git a/net/geoipupdate/distinfo b/net/geoipupdate/distinfo
new file mode 100644
index 000000000000..ba03317af80c
--- /dev/null
+++ b/net/geoipupdate/distinfo
@@ -0,0 +1,2 @@
+SHA256 (geoipupdate-2.0.2.tar.gz) = c4e86c7fb813e5937b6e87ec9a7c2489445dd4382813fbde38105a926181c548
+SIZE (geoipupdate-2.0.2.tar.gz) = 30709
diff --git a/net/geoipupdate/pkg-descr b/net/geoipupdate/pkg-descr
new file mode 100644
index 000000000000..7a120e59e6ea
--- /dev/null
+++ b/net/geoipupdate/pkg-descr
@@ -0,0 +1,10 @@
+This program is used to fetch the GeoIP2 and GeoIP databases. It requires
+an active GeoIP subscription.
+
+Please see https://www.maxmind.com/en/geolocation_landing for details about
+obtaining a subscription.
+
+If you wish to install the free versions of the GeoIP databases, please
+use the geoipudate.sh script provided in net/GeoIP.
+
+WWW: https://github.com/maxmind/geoipupdate
diff --git a/net/geoipupdate/pkg-plist b/net/geoipupdate/pkg-plist
new file mode 100644
index 000000000000..711b4260de83
--- /dev/null
+++ b/net/geoipupdate/pkg-plist
@@ -0,0 +1,4 @@
+bin/geoipupdate
+@sample etc/GeoIP.conf.sample
+man/man1/geoipupdate.1.gz
+man/man5/GeoIP.conf.5.gz