aboutsummaryrefslogtreecommitdiffstats
path: root/net/giftoxic/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2003-12-28 21:34:01 +0800
committerpav <pav@FreeBSD.org>2003-12-28 21:34:01 +0800
commitd77aa18ccae69562c908e1b4e99a0e986f540cfc (patch)
tree265a7a916e96e5fdff5f8e924d6abb6a7986617e /net/giftoxic/Makefile
parente281d5a4696884312261365e3489621d760b7aa0 (diff)
downloadfreebsd-ports-gnome-d77aa18ccae69562c908e1b4e99a0e986f540cfc.tar.gz
freebsd-ports-gnome-d77aa18ccae69562c908e1b4e99a0e986f540cfc.tar.zst
freebsd-ports-gnome-d77aa18ccae69562c908e1b4e99a0e986f540cfc.zip
Add giFToxic, a GTK2 GUI on top of giFT daemon.
PR: ports/60640 Submitted by: Joel Diaz <joeldiaz@bellsouth.net>
Diffstat (limited to 'net/giftoxic/Makefile')
-rw-r--r--net/giftoxic/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net/giftoxic/Makefile b/net/giftoxic/Makefile
new file mode 100644
index 000000000000..e879e5906eee
--- /dev/null
+++ b/net/giftoxic/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: giFToxic
+# Date Created: 23 December 2003
+# Whom: Joel Diaz <joeldiaz@bellsouth.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= giFToxic
+PORTVERSION= 0.0.9
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= giftoxic
+
+MAINTAINER= joeldiaz@bellsouth.net
+COMMENT= GTK2 client for giFT
+
+LIB_DEPENDS= gift.0:${PORTSDIR}/net/gift
+
+USE_X_PREFIX= yes
+USE_GETOPT_LONG= yes
+USE_GNOME= gtk20 gnomeprefix gnomehack
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --without-included-gettext
+
+.include <bsd.port.mk>