aboutsummaryrefslogtreecommitdiffstats
path: root/net/glflow/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-08-13 21:32:52 +0800
committerpav <pav@FreeBSD.org>2004-08-13 21:32:52 +0800
commitc0236775d5d9db39f9e38898b80ac938ce07cd00 (patch)
treebe7749f0d6cc1f8f88ebfad9ffafc8e493b9fde6 /net/glflow/Makefile
parentb597980f595d0fb9dcf3946794222ac1bc8399b4 (diff)
downloadfreebsd-ports-gnome-c0236775d5d9db39f9e38898b80ac938ce07cd00.tar.gz
freebsd-ports-gnome-c0236775d5d9db39f9e38898b80ac938ce07cd00.tar.zst
freebsd-ports-gnome-c0236775d5d9db39f9e38898b80ac938ce07cd00.zip
Add glflow, a DoS detection tool written with speed in mind.
It detects attacks on high speed links through real-time NetFlow aggregation and analysis. PR: ports/69011 Submitted by: David Thiel <lx@redundancy.redundancy.org>
Diffstat (limited to 'net/glflow/Makefile')
-rw-r--r--net/glflow/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net/glflow/Makefile b/net/glflow/Makefile
new file mode 100644
index 000000000000..786b65c8779b
--- /dev/null
+++ b/net/glflow/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: glflow
+# Date created: 2004-07-12
+# Whom: David Thiel (lx@redundancy.redundancy.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= glflow
+PORTVERSION= 0.0.4
+CATEGORIES= net security
+MASTER_SITES= http://night.rdslink.ro/dudu/glflow/
+DISTNAME= glFlow-${PORTVERSION}
+
+MAINTAINER= lx@redundancy.redundancy.org
+COMMENT= A NetFlow tool for detecting DoS attacks
+
+PLIST_FILES= bin/glflow
+PORTDOCS= README
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/glflow ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>