aboutsummaryrefslogtreecommitdiffstats
path: root/net/gnet/Makefile
diff options
context:
space:
mode:
authornakai <nakai@FreeBSD.org>2002-06-27 13:57:24 +0800
committernakai <nakai@FreeBSD.org>2002-06-27 13:57:24 +0800
commitbabca37e3aaa59bcdd49a1db23ded251afe19f23 (patch)
tree991814c74d2f71f145a8fd6a56359452b4cccf2b /net/gnet/Makefile
parent6c203a32578d0531dd36642d600990e5484420f8 (diff)
downloadfreebsd-ports-gnome-babca37e3aaa59bcdd49a1db23ded251afe19f23.tar.gz
freebsd-ports-gnome-babca37e3aaa59bcdd49a1db23ded251afe19f23.tar.zst
freebsd-ports-gnome-babca37e3aaa59bcdd49a1db23ded251afe19f23.zip
Update to 1.1.4
Submitted by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
Diffstat (limited to 'net/gnet/Makefile')
-rw-r--r--net/gnet/Makefile29
1 files changed, 28 insertions, 1 deletions
diff --git a/net/gnet/Makefile b/net/gnet/Makefile
index 416e763cc5e9..5b57166be256 100644
--- a/net/gnet/Makefile
+++ b/net/gnet/Makefile
@@ -6,14 +6,41 @@
#
PORTNAME= gnet
-PORTVERSION= 1.1.0
+PORTVERSION= 1.1.4
CATEGORIES= net
MASTER_SITES= http://www.gnetlibrary.org/src/
MAINTAINER= nakai@FreeBSD.org
+USE_REINPLACE= yes
USE_GLIB= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
+MAN1= gnet-config.1
+
+post-patch:
+# fix pthreads detection
+ @${REINPLACE_CMD} -E -e 's,-lpthread|-lc_r,${PTHREAD_LIBS},' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+# remove "release" information from lib name
+ @${REINPLACE_CMD} -E -e 's|-release[ ]+\$$\(LT_RELEASE\)||g' \
+ ${WRKSRC}/src/Makefile.in
+# don't install gnet-config script with odd name. We will install it ourselves
+ @${REINPLACE_CMD} -E -e 's|^(install-exec-am:).+$$|\1|' \
+ ${WRKSRC}/Makefile.in
+# install gnet-config.1 man (not another name). Revise at EVERY port update
+ @${REINPLACE_CMD} -e 's|\$$\$$inst|\$$\$$file|g' \
+ ${WRKSRC}/doc/Makefile.in
+# install configincludedir correctly
+ @${REINPLACE_CMD} -E -e 's|^(configincludedir).+$$|\1=\$$\(pkgincludedir\)|' \
+ ${WRKSRC}/Makefile.in
+# install *.pc files in correct FreeBSD dir
+ @${REINPLACE_CMD} -E -e \
+ 's|^(pkgconfigdir[ ]+=[ ]+)\$$\(libdir\)/(pkgconfig)|\1${PREFIX}/libdata/\2|' \
+ ${WRKSRC}/Makefile.in
+
+post-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/gnet-config ${PREFIX}/bin
+
.include <bsd.port.mk>