aboutsummaryrefslogtreecommitdiffstats
path: root/net/gnet2
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-07-20 19:45:53 +0800
committersobomax <sobomax@FreeBSD.org>2002-07-20 19:45:53 +0800
commit2132ee3879a61074b35f315fb54a201ad0d4dfd2 (patch)
tree4a4892beef5f99af0a2da0365a601eff41e76d2d /net/gnet2
parent7dd1177ddef1908acd49f4f0344e32bfd9af9dff (diff)
downloadfreebsd-ports-gnome-2132ee3879a61074b35f315fb54a201ad0d4dfd2.tar.gz
freebsd-ports-gnome-2132ee3879a61074b35f315fb54a201ad0d4dfd2.tar.zst
freebsd-ports-gnome-2132ee3879a61074b35f315fb54a201ad0d4dfd2.zip
Use USE_LIBTOOL.
Diffstat (limited to 'net/gnet2')
-rw-r--r--net/gnet2/Makefile6
-rw-r--r--net/gnet2/files/patch-configure13
-rw-r--r--net/gnet2/pkg-plist1
3 files changed, 14 insertions, 6 deletions
diff --git a/net/gnet2/Makefile b/net/gnet2/Makefile
index 83643e322dbe..ad79ea436ec5 100644
--- a/net/gnet2/Makefile
+++ b/net/gnet2/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= nakai@FreeBSD.org
USE_REINPLACE= yes
USE_GNOMENG= yes
-USE_GNOME= glib12
+USE_GNOME= gnomehack glib12
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
@@ -36,10 +36,6 @@ post-patch:
# install configincludedir correctly
@${REINPLACE_CMD} -E -e 's|^(configincludedir).+$$|\1=\$$\(pkgincludedir\)|' \
${WRKSRC}/Makefile.in
-# install *.pc files in correct FreeBSD dir
- @${REINPLACE_CMD} -E -e \
- 's|^(pkgconfigdir[ ]+=[ ]+)\$$\(libdir\)/(pkgconfig)|\1${PREFIX}/libdata/\2|' \
- ${WRKSRC}/Makefile.in
post-install:
@${INSTALL_SCRIPT} ${WRKSRC}/gnet-config ${PREFIX}/bin
diff --git a/net/gnet2/files/patch-configure b/net/gnet2/files/patch-configure
new file mode 100644
index 000000000000..0071caef4a7f
--- /dev/null
+++ b/net/gnet2/files/patch-configure
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- configure 2002/07/20 11:29:10 1.1
++++ configure 2002/07/20 11:29:19
+@@ -6725,6 +6725,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/net/gnet2/pkg-plist b/net/gnet2/pkg-plist
index 0a1adae9262b..3107cd1eff16 100644
--- a/net/gnet2/pkg-plist
+++ b/net/gnet2/pkg-plist
@@ -15,7 +15,6 @@ include/gnet/udp.h
include/gnet/unix.h
include/gnet/url.h
lib/libgnet.a
-lib/libgnet.la
lib/libgnet.so
lib/libgnet.so.1
libdata/pkgconfig/gnet.pc