aboutsummaryrefslogtreecommitdiffstats
path: root/net/gnewtellium
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-03-10 22:21:52 +0800
committerkrion <krion@FreeBSD.org>2004-03-10 22:21:52 +0800
commit0b4c80c8f4804ae8b3fa16e8dc557298809122fd (patch)
tree4f958908ceba0c3cdd303133b915bed19e86ee46 /net/gnewtellium
parentd392b3ea84efcd6c0eaeb3cee112147210d4b2b5 (diff)
downloadfreebsd-ports-gnome-0b4c80c8f4804ae8b3fa16e8dc557298809122fd.tar.gz
freebsd-ports-gnome-0b4c80c8f4804ae8b3fa16e8dc557298809122fd.tar.zst
freebsd-ports-gnome-0b4c80c8f4804ae8b3fa16e8dc557298809122fd.zip
- Fix build on -current
PR: ports/64045 Submitted by: Ports Fury
Diffstat (limited to 'net/gnewtellium')
-rw-r--r--net/gnewtellium/Makefile14
-rw-r--r--net/gnewtellium/files/patch-src::config.c55
-rw-r--r--net/gnewtellium/pkg-plist5
3 files changed, 61 insertions, 13 deletions
diff --git a/net/gnewtellium/Makefile b/net/gnewtellium/Makefile
index d90723c9981e..74b219196e5d 100644
--- a/net/gnewtellium/Makefile
+++ b/net/gnewtellium/Makefile
@@ -15,15 +15,13 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A gnutella client
USE_X_PREFIX= yes
-USE_GMAKE= yes
USE_GNOME= gtk12
+USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_AUTOCONF= yes
-
-.include <bsd.port.pre.mk>
+MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
+ AUTOHEADER="${TRUE}"
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
+PLIST_FILES= bin/gnewtellium %%DATADIR%%/pixmaps/gnewtellium.xpm
+PLIST_DIRS= %%DATADIR%%/pixmaps %%DATADIR%%
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/gnewtellium/files/patch-src::config.c b/net/gnewtellium/files/patch-src::config.c
new file mode 100644
index 000000000000..54d3eba3f8be
--- /dev/null
+++ b/net/gnewtellium/files/patch-src::config.c
@@ -0,0 +1,55 @@
+--- src/config.c.orig Tue Feb 5 03:50:18 2002
++++ src/config.c Tue Mar 9 20:37:00 2004
+@@ -539,8 +539,8 @@
+ gtk_box_pack_start(GTK_BOX(vbox), hbox, FALSE, FALSE, 0);
+ gtk_widget_show(hbox);
+
+- label = gtk_label_new("Let Newtella know what speed your Internet Connection is.
+-Setting this to an accurate number will help you get the most out of
++ label = gtk_label_new("Let Newtella know what speed your Internet Connection is.\n\
++Setting this to an accurate number will help you get the most out of\n\
+ Newtella's advanced bandwidth management.");
+ gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_LEFT);
+ hbox = gtk_hbox_new(FALSE, 0);
+@@ -579,7 +579,7 @@
+ gtk_widget_show(button);
+
+ hbox = gtk_hbox_new(FALSE, 0);
+- label = gtk_label_new("Select the directory where you want to store your newly
++ label = gtk_label_new("Select the directory where you want to store your newly\n\
+ downloaded files.");
+ gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_LEFT);
+ gtk_box_pack_start(GTK_BOX(hbox), label, FALSE, FALSE, 10);
+@@ -627,8 +627,8 @@
+ gtk_widget_show(hbox);
+ gtk_box_pack_start(GTK_BOX(vbox), hbox, FALSE, FALSE, 5);
+
+- label = gtk_label_new("Add any number of directories here.
+-All .mp3 files under any of these directories can then be
++ label = gtk_label_new("Add any number of directories here.\n\
++All .mp3 files under any of these directories can then be\n\
+ downloaded by other Newtella users.");
+ gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_LEFT);
+ hbox = gtk_hbox_new(FALSE, 0);
+@@ -686,8 +686,8 @@
+ gtk_box_pack_start(GTK_BOX(vbox), hbox, FALSE, FALSE, 10);
+
+ hbox = gtk_hbox_new(FALSE, 0);
+- label = gtk_label_new("Select how much search results Newtella will maximally send to
+-other clients. Use this to limit the impact of stupid searches on your
++ label = gtk_label_new("Select how much search results Newtella will maximally send to\n\
++other clients. Use this to limit the impact of stupid searches on your\n\
+ computer.");
+ gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_LEFT);
+ gtk_box_pack_start(GTK_BOX(hbox), label, FALSE, FALSE, 10);
+@@ -724,8 +724,8 @@
+ gtk_box_pack_start(GTK_BOX(vbox), hbox, FALSE, FALSE, 10);
+
+ hbox = gtk_hbox_new(FALSE, 0);
+- label = gtk_label_new("Returns the entered IP with search results instead of your real one.
+-Useful if your're behind a NAT Firewall (like Windows 98 Internet
++ label = gtk_label_new("Returns the entered IP with search results instead of your real one.\n\
++Useful if your're behind a NAT Firewall (like Windows 98 Internet\n\
+ Connection Sharing)");
+ gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_LEFT);
+ gtk_box_pack_start(GTK_BOX(hbox), label, FALSE, FALSE, 10);
diff --git a/net/gnewtellium/pkg-plist b/net/gnewtellium/pkg-plist
deleted file mode 100644
index f86f894a32ab..000000000000
--- a/net/gnewtellium/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-bin/gnewtellium
-share/gnewtellium/pixmaps/gnewtellium.xpm
-@dirrm share/gnewtellium/pixmaps
-@dirrm share/gnewtellium
-