aboutsummaryrefslogtreecommitdiffstats
path: root/net/gnome-nettool/Makefile
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-09-04 18:43:19 +0800
committerkwm <kwm@FreeBSD.org>2015-09-04 18:43:19 +0800
commit8616aa601ec480e35f50fc5d8855092959140dd5 (patch)
treed3a665d7053a7402b9717a84f61a49acb4eba379 /net/gnome-nettool/Makefile
parenta9219452cdcd0550e180309c48937160693304bc (diff)
downloadfreebsd-ports-gnome-8616aa601ec480e35f50fc5d8855092959140dd5.tar.gz
freebsd-ports-gnome-8616aa601ec480e35f50fc5d8855092959140dd5.tar.zst
freebsd-ports-gnome-8616aa601ec480e35f50fc5d8855092959140dd5.zip
Update gnome-nettool to 3.8.1.
Diffstat (limited to 'net/gnome-nettool/Makefile')
-rw-r--r--net/gnome-nettool/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/net/gnome-nettool/Makefile b/net/gnome-nettool/Makefile
index 74dc0b44c2ae..ce640079b66d 100644
--- a/net/gnome-nettool/Makefile
+++ b/net/gnome-nettool/Makefile
@@ -1,33 +1,33 @@
# Created by: Adam Weinberger <adamw@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/net/gnome-nettool/Makefile,v 1.58 2010/09/28 09:03:44 kwm Exp $
PORTNAME= gnome-nettool
-PORTVERSION= 2.32.0
-PORTREVISION= 1
+PORTVERSION= 3.8.1
PORTEPOCH= 1
CATEGORIES= net gnome
MASTER_SITES= GNOME
-DIST_SUBDIR= gnome2
+DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME utility that provides network information statistics
+BUILD_DEPENDS= itstool:${PORTSDIR}/textproc/itstool
LIB_DEPENDS= libgtop-2.0.so:${PORTSDIR}/devel/libgtop
-USE_GNOME= intlhack gnomeprefix libglade2 gconf2 gnomedocutils
-GNOME_DESKTOP_VERSION=2
-USES= gettext gmake libtool pathfix pkgconfig tar:bzip2
-INSTALLS_OMF= yes
+USE_GNOME= gtk30 intlhack libxml2:build
+USES= gettext gmake libtool pathfix pkgconfig tar:xz
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CFLAGS+= -DHAVE_SOCKADDR_SA_LEN
INSTALL_TARGET= install-strip
-post-install:
- ${LN} -sf ${PREFIX}/share/gnome-nettool/pixmaps/gnome-nettool.png \
- ${STAGEDIR}${PREFIX}/share/pixmaps/gnome-nettool.png
+GLIB_SCHEMAS= org.gnome.gnome-nettool.gschema.xml
+
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == DragonFly || (${OPSYS} == FreeBSD && ${OSVERSION} > 1000000)
+RUN_DEPENDS+= ${LOCALBASE}/bin/dig:${PORTSDIR}/dns/bind-tools
+.endif
.include <bsd.port.mk>