aboutsummaryrefslogtreecommitdiffstats
path: root/net/gnomenettool
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-04-30 08:47:21 +0800
committermarcus <marcus@FreeBSD.org>2006-04-30 08:47:21 +0800
commit7315b1c16ae631c60d787b73475db448b86b7e0b (patch)
tree0a7edc722d829b9a98914843c0c09d978324e75f /net/gnomenettool
parente43bffa408ddb90519bcbf271791632a33f25217 (diff)
downloadfreebsd-ports-gnome-7315b1c16ae631c60d787b73475db448b86b7e0b.tar.gz
freebsd-ports-gnome-7315b1c16ae631c60d787b73475db448b86b7e0b.tar.zst
freebsd-ports-gnome-7315b1c16ae631c60d787b73475db448b86b7e0b.zip
Presenting GNOME 2.14.1 for FreeBSD! Checkout
http://www.gnome.org/start/2.14/ for the official release notes, and a list of all the gooides in this new release. In particular, GNOME 2.14 focused on performance, and they did not miss the mark. There's some new eye candy, but most of the big things are waiting until GNOME 2.16. On the FreeBSD side, we tried to clean up all the crashers we could. In particular, we really improved GNOME's 64-bit support. The good news is that this release does not bring any big shared library version bumps, so you can almost do a simple portupgrade to get to 2.14. There are a few minor gotchas that will be documented in UPDATING shortly. The FreeBSD GNOME Team would like th thank the following users for their patches, feedback, and sometimes incessant complaing about crashes (you know who you are). Yasuda Keisuke <kysd@po.harenet.ne.jp> Pascal Hofstee <caelian@gmail.com> rmgls@wanadoo.fr tmclaugh Yuri Pankov <yuri.pankov@gmail.com> sajd on #freebsd-gnome ade ankon on #FreeBSD-Gnome mux Pascal Hofstee <caelian@gmail.com> QuiRK on #freebsd-gnome Vladimir Timofeev <vovkasm@gmail.com>
Diffstat (limited to 'net/gnomenettool')
-rw-r--r--net/gnomenettool/Makefile8
-rw-r--r--net/gnomenettool/distinfo6
-rw-r--r--net/gnomenettool/files/patch-src_info.c44
-rw-r--r--net/gnomenettool/files/patch-src_nettool.c21
-rw-r--r--net/gnomenettool/pkg-plist6
5 files changed, 59 insertions, 26 deletions
diff --git a/net/gnomenettool/Makefile b/net/gnomenettool/Makefile
index 64bd2d9d7209..ff331c15cef1 100644
--- a/net/gnomenettool/Makefile
+++ b/net/gnomenettool/Makefile
@@ -3,15 +3,16 @@
# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/net/gnomenettool/Makefile,v 1.11 2005/10/04 03:12:16 ahze Exp $
+# $MCom: ports/net/gnomenettool/Makefile,v 1.23 2006/04/24 02:02:46 marcus Exp $
#
PORTNAME= gnomenettool
-PORTVERSION= 1.4.1
+PORTVERSION= 2.14.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-nettool/1.4
+MASTER_SITE_SUBDIR= sources/gnome-nettool/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DISTNAME= gnome-nettool-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -22,6 +23,7 @@ USE_X_PREFIX= yes
USE_BZIP2= yes
USE_GNOME= gnomehack intlhack gnomeprefix libglade2 gconf2
USE_GMAKE= yes
+USE_GETTEXT= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/net/gnomenettool/distinfo b/net/gnomenettool/distinfo
index 2062ca84df73..830c528617b2 100644
--- a/net/gnomenettool/distinfo
+++ b/net/gnomenettool/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-nettool-1.4.1.tar.bz2) = a64f7b39f24b4d3a843d545f2dbb611d
-SHA256 (gnome2/gnome-nettool-1.4.1.tar.bz2) = 8b8fc47dcfddf4194c30efba4cdbf6efc96a49b1fd69b3a87461d1af383f4a91
-SIZE (gnome2/gnome-nettool-1.4.1.tar.bz2) = 477548
+MD5 (gnome2/gnome-nettool-2.14.1.tar.bz2) = d7693bf04adfdb5d3a64dafb1c59cb3c
+SHA256 (gnome2/gnome-nettool-2.14.1.tar.bz2) = 9ec757eed3315c12e1e1ca84d3deed6f3ad7d82dc9005608e33768559be6ead7
+SIZE (gnome2/gnome-nettool-2.14.1.tar.bz2) = 490947
diff --git a/net/gnomenettool/files/patch-src_info.c b/net/gnomenettool/files/patch-src_info.c
index 9b895e8fd67f..7faf5e433c9b 100644
--- a/net/gnomenettool/files/patch-src_info.c
+++ b/net/gnomenettool/files/patch-src_info.c
@@ -1,15 +1,17 @@
---- src/info.c.orig Thu Jan 27 18:26:53 2005
-+++ src/info.c Sun Jul 3 17:46:31 2005
-@@ -20,6 +20,8 @@
+--- src/info.c.orig Mon Apr 3 15:41:33 2006
++++ src/info.c Sun Apr 23 21:57:39 2006
+@@ -20,6 +20,10 @@
#include <gtk/gtk.h>
#include <glib/gi18n.h>
#include <glib/gprintf.h>
+#include <sys/types.h>
+#include <string.h>
++#include <errno.h>
++#include <unistd.h>
#ifdef HAVE_CONFIG_H
# include <config.h>
-@@ -38,6 +40,11 @@
+@@ -38,6 +42,11 @@
#include <sys/ioctl.h>
#include <stdlib.h>
#include <net/if.h>
@@ -21,7 +23,7 @@
#include "info.h"
#include "utils.h"
-@@ -58,6 +65,7 @@ static InfoInterfaceDescription info_ifa
+@@ -58,6 +67,7 @@ static InfoInterfaceDescription info_ifa
{ N_("Ethernet Interface"), INFO_INTERFACE_ETH, "16_ethernet.xpm", "eth", NULL },
{ N_("Wireless Interface"), INFO_INTERFACE_WLAN, "wavelan-16.png", "wlan", NULL },
{ N_("Modem Interface"), INFO_INTERFACE_PPP, "16_ppp.xpm", "ppp", NULL },
@@ -29,7 +31,7 @@
{ N_("Parallel Line Interface"), INFO_INTERFACE_PLIP, "16_plip.xpm", "plip", NULL },
{ N_("Infrared Interface"), INFO_INTERFACE_IRLAN, "irda-16.png", "irlan", NULL },
{ N_("Loopback Interface"), INFO_INTERFACE_LO, "16_loopback.xpm", "lo", NULL },
-@@ -128,9 +136,42 @@ info_get_interface_from_dev_name (const
+@@ -128,9 +138,42 @@ info_get_interface_from_dev_name (const
{
gint i;
gchar *path;
@@ -71,10 +73,10 @@
for (i = 0; info_iface_desc[i].name; i++)
- if (strstr (dev_name, info_iface_desc[i].prefix) == dev_name) {
+ if (strstr (dev_type, info_iface_desc[i].prefix) == dev_type) {
- (*iface) = g_strdup_printf ("%s (%s)", info_iface_desc[i].name, dev_name);
+ (*iface) = g_strdup_printf ("%s (%s)", _(info_iface_desc[i].name), dev_name);
if (info_iface_desc[i].pixbuf == NULL) {
path = g_build_filename (PIXMAPS_DIR, info_iface_desc[i].icon, NULL);
-@@ -217,38 +258,87 @@ info_nic_update_stats (gpointer data)
+@@ -217,38 +260,87 @@ info_nic_update_stats (gpointer data)
gchar tx[10], tx_error[10], tx_drop[10], tx_ovr[10];
*/
gchar iface[30]; /*, flags[30]; */
@@ -168,7 +170,7 @@
if (g_ascii_strcasecmp (iface, text) == 0) {
/*
-@@ -276,7 +366,9 @@ info_nic_update_stats (gpointer data)
+@@ -276,7 +368,9 @@ info_nic_update_stats (gpointer data)
}
g_io_channel_unref (io);
@@ -179,24 +181,29 @@
return TRUE;
}
-@@ -405,8 +497,16 @@ info_get_nic_information (const gchar *n
+@@ -405,8 +499,20 @@ info_get_nic_information (const gchar *n
InfoIpAddr *ip;
gint flags;
mii_data_result data;
+#ifdef __FreeBSD__
-+ gint hwmib[6], hwlen;
++ gint hwmib[6];
++ size_t hwlen;
+ gchar *hwbuf;
+ guchar *hwptr;
+ struct if_msghdr *hwifm;
+ struct sockaddr_dl *hwsinptr;
+#endif
- getifaddrs (&ifa0);
+- getifaddrs (&ifa0);
++ if (getifaddrs (&ifa0) != 0) {
++ g_warning ("getifaddrs failed: %s", g_strerror (errno));
++ goto fail;
++ }
+ memset (&data, 0, sizeof (data));
for (ifr6 = ifa0; ifr6; ifr6 = ifr6->ifa_next) {
if (strcmp (ifr6->ifa_name, nic) != 0) {
-@@ -452,7 +552,9 @@ info_get_nic_information (const gchar *n
+@@ -452,7 +558,9 @@ info_get_nic_information (const gchar *n
ifc.ifc_req = (struct ifreq *) buf;
ioctl (sockfd, SIOCGIFCONF, &ifc);
@@ -206,7 +213,7 @@
for (ptr = buf; ptr < buf + ifc.ifc_len;) {
ifr = (struct ifreq *) ptr;
-@@ -483,6 +585,45 @@ info_get_nic_information (const gchar *n
+@@ -483,6 +591,45 @@ info_get_nic_information (const gchar *n
(int) ((guchar *) &ifrcopy.ifr_hwaddr.sa_data)[3],
(int) ((guchar *) &ifrcopy.ifr_hwaddr.sa_data)[4],
(int) ((guchar *) &ifrcopy.ifr_hwaddr.sa_data)[5]);
@@ -252,3 +259,12 @@
#else
g_sprintf (dst, NOT_AVAILABLE);
#endif /* SIOCGIFHWADDR */
+@@ -595,6 +742,8 @@ info_get_nic_information (const gchar *n
+ }
+
+ freeifaddrs (ifa0);
++fail:
++ ;
+ }
+
+ static gint *
diff --git a/net/gnomenettool/files/patch-src_nettool.c b/net/gnomenettool/files/patch-src_nettool.c
index cae4f648fdf8..d8ac21225fdd 100644
--- a/net/gnomenettool/files/patch-src_nettool.c
+++ b/net/gnomenettool/files/patch-src_nettool.c
@@ -1,14 +1,23 @@
---- src/nettool.c.orig Fri Jan 7 23:13:56 2005
-+++ src/nettool.c Mon Jan 24 21:03:48 2005
-@@ -22,6 +22,7 @@
- #include <glib/gi18n.h>
+--- src/nettool.c.orig Tue May 10 18:14:48 2005
++++ src/nettool.c Sun Apr 23 22:00:13 2006
+@@ -24,6 +24,7 @@
+ #include <string.h>
#include <sys/types.h>
#include <sys/socket.h>
+#include <netinet/in.h>
#include <signal.h>
#include <errno.h>
#include <sys/wait.h>
-@@ -357,6 +358,10 @@
+@@ -315,7 +316,7 @@ netinfo_io_text_buffer_dialog (GIOChanne
+ GIOCondition condition, gpointer data)
+ {
+ gchar *text = NULL;
+- gint len;
++ gsize len;
+ Netinfo *netinfo = (Netinfo *) data;
+
+ g_return_val_if_fail (channel != NULL, FALSE);
+@@ -360,6 +361,10 @@ netinfo_io_text_buffer_dialog (GIOChanne
len, NULL);
}
@@ -19,7 +28,7 @@
} else if (status == G_IO_STATUS_AGAIN) {
char buf[1];
-@@ -368,12 +373,13 @@
+@@ -371,12 +376,13 @@ netinfo_io_text_buffer_dialog (GIOChanne
}
g_string_append_c (netinfo->command_output, buf[0]);
}
diff --git a/net/gnomenettool/pkg-plist b/net/gnomenettool/pkg-plist
index 0d3d6886cd50..531ea6a3d90c 100644
--- a/net/gnomenettool/pkg-plist
+++ b/net/gnomenettool/pkg-plist
@@ -17,8 +17,10 @@ share/locale/bn/LC_MESSAGES/gnome-nettool.mo
share/locale/bs/LC_MESSAGES/gnome-nettool.mo
share/locale/ca/LC_MESSAGES/gnome-nettool.mo
share/locale/cs/LC_MESSAGES/gnome-nettool.mo
+share/locale/cy/LC_MESSAGES/gnome-nettool.mo
share/locale/da/LC_MESSAGES/gnome-nettool.mo
share/locale/de/LC_MESSAGES/gnome-nettool.mo
+share/locale/dz/LC_MESSAGES/gnome-nettool.mo
share/locale/el/LC_MESSAGES/gnome-nettool.mo
share/locale/en_CA/LC_MESSAGES/gnome-nettool.mo
share/locale/en_GB/LC_MESSAGES/gnome-nettool.mo
@@ -32,11 +34,13 @@ share/locale/ga/LC_MESSAGES/gnome-nettool.mo
share/locale/gl/LC_MESSAGES/gnome-nettool.mo
share/locale/gu/LC_MESSAGES/gnome-nettool.mo
share/locale/he/LC_MESSAGES/gnome-nettool.mo
+share/locale/hi/LC_MESSAGES/gnome-nettool.mo
share/locale/hr/LC_MESSAGES/gnome-nettool.mo
share/locale/hu/LC_MESSAGES/gnome-nettool.mo
share/locale/id/LC_MESSAGES/gnome-nettool.mo
share/locale/it/LC_MESSAGES/gnome-nettool.mo
share/locale/ja/LC_MESSAGES/gnome-nettool.mo
+share/locale/ka/LC_MESSAGES/gnome-nettool.mo
share/locale/ko/LC_MESSAGES/gnome-nettool.mo
share/locale/lt/LC_MESSAGES/gnome-nettool.mo
share/locale/mk/LC_MESSAGES/gnome-nettool.mo
@@ -68,6 +72,8 @@ share/locale/wa/LC_MESSAGES/gnome-nettool.mo
share/locale/xh/LC_MESSAGES/gnome-nettool.mo
share/locale/zh_CN/LC_MESSAGES/gnome-nettool.mo
share/locale/zh_TW/LC_MESSAGES/gnome-nettool.mo
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
@dirrm share/gnome/gnome-nettool/pixmaps
@dirrm share/gnome/gnome-nettool/dialogs
@dirrm share/gnome/gnome-nettool