aboutsummaryrefslogtreecommitdiffstats
path: root/net/gnu-finger
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2003-10-16 17:34:30 +0800
committerosa <osa@FreeBSD.org>2003-10-16 17:34:30 +0800
commite40c04e8b837299f7766379441585ee98986e2a5 (patch)
tree7e95d1ff893980aa127e9da3508b4be05f46b356 /net/gnu-finger
parent95d7ef10c80035b4fbe3899f622b843339a7b2a8 (diff)
downloadfreebsd-ports-gnome-e40c04e8b837299f7766379441585ee98986e2a5.tar.gz
freebsd-ports-gnome-e40c04e8b837299f7766379441585ee98986e2a5.tar.zst
freebsd-ports-gnome-e40c04e8b837299f7766379441585ee98986e2a5.zip
Fix build on -CURRENT [1]
Also make portlint(1) much more happy: remove hyphen from PORTNAME and add PKGNAMEPREFIX; fix pkg-plist; Bump PORTREVISION. Submitted by: Cheng-Lung Sung <clsung@dragon2.net> [1], osa PR: 58062
Diffstat (limited to 'net/gnu-finger')
-rw-r--r--net/gnu-finger/Makefile31
-rw-r--r--net/gnu-finger/pkg-descr9
2 files changed, 21 insertions, 19 deletions
diff --git a/net/gnu-finger/Makefile b/net/gnu-finger/Makefile
index f5ee9f18b1a2..1d5ce91ab1b7 100644
--- a/net/gnu-finger/Makefile
+++ b/net/gnu-finger/Makefile
@@ -1,27 +1,36 @@
-# New ports collection makefile for: GNU finger
-# Date created: 20 June 1996
-# Whom: Yoshiro MIHIRA <sanpei@yy.cs.keio.ac.jp>
+# New ports collection makefile for: GNU finger
+# Date created: 20 June 1996
+# Whom: Yoshiro MIHIRA <sanpei@yy.cs.keio.ac.jp>
#
# $FreeBSD$
#
-PORTNAME= gnu-finger
+PORTNAME= finger
PORTVERSION= 1.37
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= finger
-DISTNAME= finger-1.37
+PKGNAMEPREFIX= gnu-
MAINTAINER= ports@FreeBSD.org
COMMENT= GNU version of finger
-.include <bsd.port.pre.mk>
-
CONFLICTS= pfinger-0.*
-.if ${OSVERSION} >= 500000
-BROKEN= does not compile on 5.x
-.endif
+USE_REINPLACE= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,DEFS="$$DEFS -D_ANSI_SOURCE",,' \
+ ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's,extern char \*sys_errlist,//extern char \*sys_errlist,' \
+ ${WRKSRC}/lib/os.c ${WRKSRC}/lib/error.c
+ ${REINPLACE_CMD} -e 's,longjmperror (),void longjmperror (void),' \
+ ${WRKSRC}/lib/error.c
+ ${REINPLACE_CMD} -e 's,\, sys_nerr,,' \
+ ${WRKSRC}/lib/error.c
+ ${REINPLACE_CMD} -e 's,char \*source,const char \*source,' \
+ ${WRKSRC}/lib/savedir.c
HAS_CONFIGURE= yes
INSTALL_TARGET= server
@@ -35,4 +44,4 @@ post-install:
@${ECHO_CMD} "GNU.finger.server.hostname" > ${PREFIX}/etc/fingerdir/serverhost.sample
@${ECHO_CMD} "mail.spool.server.hostname" > ${PREFIX}/etc/fingerdir/mailhost.sample
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/gnu-finger/pkg-descr b/net/gnu-finger/pkg-descr
index 5af0e94a4ab1..8ce59604fa81 100644
--- a/net/gnu-finger/pkg-descr
+++ b/net/gnu-finger/pkg-descr
@@ -4,24 +4,17 @@
This ports collection is install some daemon programs,
to /usr/local/libexec, *NOT* to /usr/local/etc.
-* how to quick install: *
-
-1) Pleae rewrite collectory serverhost,clients,mailhost for your site.
+1) Please rewrite collectory serverhost,clients,mailhost for your site.
Sample file is in /usr/local/etc/fingerdir.
-
2) Add below lines to /etc/inetd.conf
cfingerd stream tcp nowait nobody /usr/local/libexec/in.cfingerd in.cfingerd
finger stream tcp nowait nobody /usr/local/libexec/in.fingerd in.fingerd
3) Comment out old finger line in /etc/inetd.conf
-
#finger stream tcp nowait nobody /usr/libexec/fingerd fingerd -s
-
4) Restart inetd
-
% kill -HUP `cat /var/run/inetd.pid`
-
5) If this host is GNU finger server host,
rename fingerd.sh.sample to fingerd.sh in /usr/local/etc/rc.d directory.
And exec fingerd.sh.