aboutsummaryrefslogtreecommitdiffstats
path: root/net/gnu-radius/Makefile
diff options
context:
space:
mode:
authorvsevolod <vsevolod@FreeBSD.org>2005-07-28 14:40:01 +0800
committervsevolod <vsevolod@FreeBSD.org>2005-07-28 14:40:01 +0800
commitf9eab265fba118e125de0ca9d064edb6851cb264 (patch)
tree8e49c64dd9513a62175ca04dc716b74862160a32 /net/gnu-radius/Makefile
parentfa4328527079d7847c9d94bebbbf991242008ad5 (diff)
downloadfreebsd-ports-gnome-f9eab265fba118e125de0ca9d064edb6851cb264.tar.gz
freebsd-ports-gnome-f9eab265fba118e125de0ca9d064edb6851cb264.tar.zst
freebsd-ports-gnome-f9eab265fba118e125de0ca9d064edb6851cb264.zip
Use libtool13 as libtool15 doesn't work with this port (dynamic modules
load fails). Do not remove config files, install -dist versions instead. Approved by: perky (mentor) Special thanks to: Anton Yuzhaninov <citrin@citrin.ru>
Diffstat (limited to 'net/gnu-radius/Makefile')
-rw-r--r--net/gnu-radius/Makefile24
1 files changed, 19 insertions, 5 deletions
diff --git a/net/gnu-radius/Makefile b/net/gnu-radius/Makefile
index 0eee57c28287..23f2c8c6790b 100644
--- a/net/gnu-radius/Makefile
+++ b/net/gnu-radius/Makefile
@@ -6,6 +6,7 @@
PORTNAME= gnu-radius
PORTVERSION= 1.3
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= radius
@@ -19,13 +20,14 @@ USE_RC_SUBR= yes
USE_SUBMAKE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_LIBTOOL_VER= 15
+USE_LIBTOOL_VER= 13
INSTALLS_SHLIB= yes
USE_GETTEXT= yes
USE_LIBLTDL= yes
CONFIGURE_TARGET= # empty
PLIST_SUB= PORTVERSION=${PORTVERSION}
+SUB_FILES= radiusd.sh
DATADIR= ${PREFIX}/share/radius
INFO= radius
@@ -47,6 +49,12 @@ OPTIONS= CLIENT "Enable build client" off \
NOTIFY "Enable TTL notification" off \
EMACS "Enable emacs dotfiles install" off
+CONFIG_FILES= access.deny client.conf clients config dictionary \
+ hints huntgroups naslist nastypes realms \
+ sqlserver users
+EXAMPLE_FILES= README ascend.rw c3620.rw cisco.rw comos.rw config.syntax \
+ filter.rw hints-0.96 jetstream.rw nt.rw pam.conf radius.php
+
.include <bsd.port.pre.mk>
.if defined(WITH_SNMP)
@@ -104,11 +112,17 @@ CONFIGURE_ARGS+= --without-lispdir
PLIST_SUB+= EMACS="@comment "
.endif
-post-patch:
- @${SED} -e "s|%%PREFIX%%|${PREFIX}|g" -e "s|%%RC_SUBR%%|${RC_SUBR}|g" \
- < ${FILESDIR}/radiusd.sh > ${WRKDIR}/radiusd.sh
-
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/radiusd.sh ${PREFIX}/etc/rc.d/radiusd.sh
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+. for ex_file in ${EXAMPLE_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/examples/${ex_file} ${EXAMPLESDIR}
+. endfor
+.endif
+.for conf_file in ${CONFIG_FILES}
+ @test -f ${PREFIX}/etc/raddb/${conf_file} || ${CP} -p \
+ ${PREFIX}/etc/raddb/${conf_file}-dist ${PREFIX}/etc/raddb/${conf_file}
+.endfor
.include <bsd.port.post.mk>