aboutsummaryrefslogtreecommitdiffstats
path: root/net/googolplex
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-02-09 18:11:49 +0800
committerijliao <ijliao@FreeBSD.org>2002-02-09 18:11:49 +0800
commit7e6b629b66f89e009b56c5a661d6d5ca5fceb6b7 (patch)
treea7e7a08c77d2ee0616a67338327f9c2f870b0f82 /net/googolplex
parenteb82e27f577218c8900b8b313477df7e4b4cd041 (diff)
downloadfreebsd-ports-gnome-7e6b629b66f89e009b56c5a661d6d5ca5fceb6b7.tar.gz
freebsd-ports-gnome-7e6b629b66f89e009b56c5a661d6d5ca5fceb6b7.tar.zst
freebsd-ports-gnome-7e6b629b66f89e009b56c5a661d6d5ca5fceb6b7.zip
add googolplex 0.1.0
Query Google, parse it and returns the result as a list
Diffstat (limited to 'net/googolplex')
-rw-r--r--net/googolplex/Makefile22
-rw-r--r--net/googolplex/distinfo1
-rw-r--r--net/googolplex/pkg-comment1
-rw-r--r--net/googolplex/pkg-descr3
-rw-r--r--net/googolplex/pkg-plist1
5 files changed, 28 insertions, 0 deletions
diff --git a/net/googolplex/Makefile b/net/googolplex/Makefile
new file mode 100644
index 000000000000..dd6256547b64
--- /dev/null
+++ b/net/googolplex/Makefile
@@ -0,0 +1,22 @@
+# ex:ts=8
+# Ports collection makefile for: googolplex
+# Date created: Feb 9, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= googolplex
+PORTVERSION= 0.1.0
+CATEGORIES= net python
+MASTER_SITES= http://googolplex.sourceforge.net/source/
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/googolplex.py ${PYTHON_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/net/googolplex/distinfo b/net/googolplex/distinfo
new file mode 100644
index 000000000000..3edd592f08e2
--- /dev/null
+++ b/net/googolplex/distinfo
@@ -0,0 +1 @@
+MD5 (googolplex-0.1.0.tar.gz) = ca40065eb88fef63a3743de5a90e7b64
diff --git a/net/googolplex/pkg-comment b/net/googolplex/pkg-comment
new file mode 100644
index 000000000000..d7f5dc42ee66
--- /dev/null
+++ b/net/googolplex/pkg-comment
@@ -0,0 +1 @@
+Query Google, parse it and returns the result as a list
diff --git a/net/googolplex/pkg-descr b/net/googolplex/pkg-descr
new file mode 100644
index 000000000000..c57b13ac7e82
--- /dev/null
+++ b/net/googolplex/pkg-descr
@@ -0,0 +1,3 @@
+Googolplex is just a Python class to do a query on http://www.google.com, parse it and returns the result as a list.
+
+WWW: http://googolplex.sourceforge.net/
diff --git a/net/googolplex/pkg-plist b/net/googolplex/pkg-plist
new file mode 100644
index 000000000000..3e7651bf762f
--- /dev/null
+++ b/net/googolplex/pkg-plist
@@ -0,0 +1 @@
+lib/%%PYTHON_VERSION%%/site-packages/googolplex.py