aboutsummaryrefslogtreecommitdiffstats
path: root/net/gps/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-03-01 11:12:06 +0800
committerijliao <ijliao@FreeBSD.org>2002-03-01 11:12:06 +0800
commit0d54bd36c0979d460cce299ed2ab4a586d01c8f0 (patch)
tree95724971070988c07ed451f6823752670226af8c /net/gps/Makefile
parent21e3fe3d93ac33dfa8b8bc63c0f00cda49851ce7 (diff)
downloadfreebsd-ports-gnome-0d54bd36c0979d460cce299ed2ab4a586d01c8f0.tar.gz
freebsd-ports-gnome-0d54bd36c0979d460cce299ed2ab4a586d01c8f0.tar.zst
freebsd-ports-gnome-0d54bd36c0979d460cce299ed2ab4a586d01c8f0.zip
add gps 0.9.1
Ghost Port Scan
Diffstat (limited to 'net/gps/Makefile')
-rw-r--r--net/gps/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/net/gps/Makefile b/net/gps/Makefile
new file mode 100644
index 000000000000..ece2313172bc
--- /dev/null
+++ b/net/gps/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# New ports collection makefile for: gps
+# Date created: Nov 25, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gps
+PORTVERSION= 0.9.1
+CATEGORIES= net
+MASTER_SITES= http://gps.sourceforge.net/release/
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+USE_GMAKE= yes
+
+post-patch:
+ @${PERL} -pi -e "s,-Wall -O3,${CFLAGS},g" ${WRKSRC}/configure
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ ${CP} ${WRKSRC}/docs/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>