aboutsummaryrefslogtreecommitdiffstats
path: root/net/grive2
diff options
context:
space:
mode:
authorcpm <cpm@FreeBSD.org>2016-09-09 07:51:57 +0800
committercpm <cpm@FreeBSD.org>2016-09-09 07:51:57 +0800
commit33f23add5b8072b78d16c304eff4a59d0adbf090 (patch)
tree3e4991f1b9f537b6eb0b4a89b8c0464e6abe80f5 /net/grive2
parent9c900d9db776d12b19027ba4acd71eaa6e3a7a49 (diff)
downloadfreebsd-ports-gnome-33f23add5b8072b78d16c304eff4a59d0adbf090.tar.gz
freebsd-ports-gnome-33f23add5b8072b78d16c304eff4a59d0adbf090.tar.zst
freebsd-ports-gnome-33f23add5b8072b78d16c304eff4a59d0adbf090.zip
New port: net/grive2 Open source client for Google Drive
Grive2 is the fork of original "Grive" Google Drive client with the support for the new Drive REST API and partial sync. WWW: https://github.com/vitalif/grive2/ Submitted by: me Reviewed by: amdmi3, feld (mentors) Approved by: amdmi3, feld (mentors) Differential Revision: D7675
Diffstat (limited to 'net/grive2')
-rw-r--r--net/grive2/Makefile32
-rw-r--r--net/grive2/distinfo3
-rw-r--r--net/grive2/files/patch-grive_CMakeLists.txt8
-rw-r--r--net/grive2/files/patch-libgrive_src_util_File.cc10
-rw-r--r--net/grive2/pkg-descr4
5 files changed, 57 insertions, 0 deletions
diff --git a/net/grive2/Makefile b/net/grive2/Makefile
new file mode 100644
index 000000000000..a8524069bcb4
--- /dev/null
+++ b/net/grive2/Makefile
@@ -0,0 +1,32 @@
+# Created by: Carlos J Puga Medina <cpm@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= grive2
+PORTVERSION= 0.5.0
+DISTVERSIONPREFIX= v
+CATEGORIES= net
+
+MAINTAINER= cpm@FreeBSD.org
+COMMENT= Open source client for Google Drive
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libboost_filesystem.so:devel/boost-libs \
+ libcurl.so:ftp/curl \
+ libexpat.so:textproc/expat2 \
+ libgcrypt.so:security/libgcrypt \
+ libgpg-error.so:security/libgpg-error \
+ libyajl.so:devel/yajl
+
+CONFLICTS_INSTALL= grive-[0-9]*
+
+USE_GITHUB= yes
+GH_ACCOUNT= vitalif
+
+USES= cmake pkgconfig localbase
+
+PLIST_FILES= bin/grive \
+ man/man1/grive.1.gz
+
+.include <bsd.port.mk>
diff --git a/net/grive2/distinfo b/net/grive2/distinfo
new file mode 100644
index 000000000000..22491f4ed072
--- /dev/null
+++ b/net/grive2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1472387091
+SHA256 (vitalif-grive2-v0.5.0_GH0.tar.gz) = 24641ef4802eb93bb55e7069bca55c4fb8aa17fd88833b9c89a1b2ee7d266567
+SIZE (vitalif-grive2-v0.5.0_GH0.tar.gz) = 162886
diff --git a/net/grive2/files/patch-grive_CMakeLists.txt b/net/grive2/files/patch-grive_CMakeLists.txt
new file mode 100644
index 000000000000..09bd5176da48
--- /dev/null
+++ b/net/grive2/files/patch-grive_CMakeLists.txt
@@ -0,0 +1,8 @@
+--- grive/CMakeLists.txt.orig 2016-01-14 20:51:31 UTC
++++ grive/CMakeLists.txt
+@@ -26,4 +26,4 @@ set_target_properties( grive_executable
+ )
+
+ install(TARGETS grive_executable RUNTIME DESTINATION bin)
+-install(FILES doc/grive.1 DESTINATION share/man/man1 )
++install(FILES doc/grive.1 DESTINATION man/man1 )
diff --git a/net/grive2/files/patch-libgrive_src_util_File.cc b/net/grive2/files/patch-libgrive_src_util_File.cc
new file mode 100644
index 000000000000..293a2eef42fe
--- /dev/null
+++ b/net/grive2/files/patch-libgrive_src_util_File.cc
@@ -0,0 +1,10 @@
+--- libgrive/src/util/File.cc.orig 2016-08-28 12:56:18 UTC
++++ libgrive/src/util/File.cc
+@@ -32,6 +32,7 @@
+ #include <sys/stat.h>
+ #include <sys/types.h>
+ #include <fcntl.h>
++#include <unistd.h>
+
+ #ifdef WIN32
+ #include <io.h>
diff --git a/net/grive2/pkg-descr b/net/grive2/pkg-descr
new file mode 100644
index 000000000000..40b7018e6e5b
--- /dev/null
+++ b/net/grive2/pkg-descr
@@ -0,0 +1,4 @@
+Grive2 is the fork of original "Grive" Google Drive client with the
+support for the new Drive REST API and partial sync.
+
+WWW: https://github.com/vitalif/grive2/