aboutsummaryrefslogtreecommitdiffstats
path: root/net/gspoof/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-08-31 01:04:34 +0800
committerkrion <krion@FreeBSD.org>2003-08-31 01:04:34 +0800
commit5842295de36bdb145047df65cbf3d727716b5684 (patch)
tree3ef171b4286759b5e6dc82e2de442cf55c721718 /net/gspoof/Makefile
parent5f0a84fee2b9f2c4791cbd6274d2c488e917c8b9 (diff)
downloadfreebsd-ports-gnome-5842295de36bdb145047df65cbf3d727716b5684.tar.gz
freebsd-ports-gnome-5842295de36bdb145047df65cbf3d727716b5684.tar.zst
freebsd-ports-gnome-5842295de36bdb145047df65cbf3d727716b5684.zip
- Update to version 3.0
PR: 56195 Submitted by: Ports Fury
Diffstat (limited to 'net/gspoof/Makefile')
-rw-r--r--net/gspoof/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/net/gspoof/Makefile b/net/gspoof/Makefile
index 58796f3f5b11..4295fb3d5042 100644
--- a/net/gspoof/Makefile
+++ b/net/gspoof/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= gspoof
-PORTVERSION= 2.1.1
-PORTREVISION= 1
+PORTVERSION= 3.0
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,19 +17,23 @@ COMMENT= Console/GTK+ TCP/IP Packets Forger
BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet-devel
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-USE_GETOPT_LONG= yes
-USE_GNOME= gtk12
+USE_GNOME= gnometarget gtk20
USE_REINPLACE= yes
-MAKE_ARGS= CC="${CC} ${CFLAGS} ${CPPFLAGS} ${LDFLAGS}"
-ALL_TARGET= gtk
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
post-patch:
- @${REINPLACE_CMD} -e "s|gtk-config|\$${GTK_CONFIG}|g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|/usr/local/lib|${LOCALBASE}/lib|g ; \
+ s|/usr/local/include|${LOCALBASE}/include|g ; \
+ s|-Wall -O2|$${CFLAGS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-Wall -O2|@CFLAGS@|g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|/usr/local/share|${PREFIX}/share|g ; \
+ s|/usr/share|${X11BASE}/share|g' ${WRKSRC}/gtk.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gspoof ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}/pixmap
+ ${INSTALL_DATA} ${WRKSRC}/pixmap/icon.png ${DATADIR}/pixmap
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}