aboutsummaryrefslogtreecommitdiffstats
path: root/net/hawknl-devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /net/hawknl-devel
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'net/hawknl-devel')
-rw-r--r--net/hawknl-devel/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/net/hawknl-devel/Makefile b/net/hawknl-devel/Makefile
index a7b63c42ee79..beb26187bb3e 100644
--- a/net/hawknl-devel/Makefile
+++ b/net/hawknl-devel/Makefile
@@ -22,10 +22,10 @@ USE_ZIP= yes
USE_DOS2UNIX= yes
USE_GMAKE= yes
MAKEFILE= makefile.linux
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
-LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
-CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS= -I${LOCALBASE}/include
MAKE_ENV= CC="${CC}" CFLAGS="${CFLAGS} ${OPTFLAGS}" \
LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
@@ -35,7 +35,7 @@ OPTIONS= OPTIMIZATION "Enable optimization" off
.include <bsd.port.pre.mk>
-.if ${ARCH} == amd64 || ${ARCH} == ia64
+.if ${ARCH} == amd64 || ${ARCH} == ia64
BROKEN= does not compile on ${ARCH}
.endif