aboutsummaryrefslogtreecommitdiffstats
path: root/net/honeyd
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-04-29 20:33:12 +0800
committerpav <pav@FreeBSD.org>2006-04-29 20:33:12 +0800
commita1323bfd6acfc7668e42b80c04e735a6d554a3e8 (patch)
treec5ebfbc9dc1d9d022f2039810b8bcf19000a925f /net/honeyd
parent7b156377d9285c113468ac1e623097f6e271c425 (diff)
downloadfreebsd-ports-gnome-a1323bfd6acfc7668e42b80c04e735a6d554a3e8.tar.gz
freebsd-ports-gnome-a1323bfd6acfc7668e42b80c04e735a6d554a3e8.tar.zst
freebsd-ports-gnome-a1323bfd6acfc7668e42b80c04e735a6d554a3e8.zip
- Update to 1.5a
- Take over maintaining PR: ports/96318 Submitted by: Wesley Shields <wxs@csh.rit.edu> Approved by: Yann Berthier <yb@bashibuzuk.net> (maintainer)
Diffstat (limited to 'net/honeyd')
-rw-r--r--net/honeyd/Makefile19
-rw-r--r--net/honeyd/distinfo6
-rw-r--r--net/honeyd/files/patch-config.c11
-rw-r--r--net/honeyd/files/patch-dhcpclient.c26
-rw-r--r--net/honeyd/files/patch-honeyd.h20
-rw-r--r--net/honeyd/files/patch-lex.c74
-rw-r--r--net/honeyd/files/patch-rrdtool.c20
-rw-r--r--net/honeyd/pkg-plist63
8 files changed, 51 insertions, 188 deletions
diff --git a/net/honeyd/Makefile b/net/honeyd/Makefile
index ea01d163a82c..93c9bd37e6ab 100644
--- a/net/honeyd/Makefile
+++ b/net/honeyd/Makefile
@@ -6,26 +6,25 @@
#
PORTNAME= honeyd
-PORTVERSION= 1.0
-PORTREVISION= 1
+PORTVERSION= 1.5a
CATEGORIES= net
MASTER_SITES= http://www.citi.umich.edu/u/provos/honeyd/ \
http://niels.xtdnet.nl/honeyd/
-MAINTAINER= yb@bashibuzuk.net
+MAINTAINER= wxs@csh.rit.edu
COMMENT= Simulate virtual network hosts (honeypots)
BUILD_DEPENDS= ${LOCALBASE}/lib/libdnet.a:${PORTSDIR}/net/libdnet \
- ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent
+ ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent \
+ ${LOCALBASE}/lib/libdnsres.a:${PORTSDIR}/devel/libdnsres \
+ ${LOCALBASE}/lib/libpcre.a:${PORTSDIR}/devel/pcre
-#OPTIONS= PYTHON "Enable Python support" off
-USE_REINPLACE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-libdnet=${LOCALBASE} \
--with-libevent=${LOCALBASE} \
- --with-pcap
+ --with-libdnsres=${LOCALBASE}
.if defined(WITH_PYTHON)
USE_PYTHON= yes
@@ -38,6 +37,7 @@ MAN1= honeydctl.1
MAN8= honeyd.8
.include <bsd.port.pre.mk>
+
.if ${OSVERSION} < 500000
LIB_DEPENDS+= edit.6:${PORTSDIR}/devel/libedit
.endif
@@ -54,6 +54,11 @@ post-configure:
@${REINPLACE_CMD} -e 's|LIBS = |LIBS = ${PTHREAD_LIBS}|' \
${WRKSRC}/Makefile
+# Have to make this directory, the Makefile is stupid and tries to
+# install stuff here without making it.
+pre-install:
+ @${MKDIR} ${DATADIR}/webserver
+
post-install:
@${MKDIR} ${DATADIR}/scripts/snmp
@cd ${WRKSRC}/scripts && \
diff --git a/net/honeyd/distinfo b/net/honeyd/distinfo
index 69d008de8cfc..df813b21b22a 100644
--- a/net/honeyd/distinfo
+++ b/net/honeyd/distinfo
@@ -1,3 +1,3 @@
-MD5 (honeyd-1.0.tar.gz) = 5c5c6cc62d135075d021a6c1bc5c9a5b
-SHA256 (honeyd-1.0.tar.gz) = 5a8763391d02969779ce3af6bb0a10e3959f72886d3f64fec9e3ee431a424967
-SIZE (honeyd-1.0.tar.gz) = 600339
+MD5 (honeyd-1.5a.tar.gz) = 5bec8d97c235f910aa56e83ba7d302bc
+SHA256 (honeyd-1.5a.tar.gz) = 86ada31e91c28c29bdb7a4b841b5014cb3f78747adc7d209b623573e82a6be83
+SIZE (honeyd-1.5a.tar.gz) = 893323
diff --git a/net/honeyd/files/patch-config.c b/net/honeyd/files/patch-config.c
deleted file mode 100644
index 67e8535e8c1e..000000000000
--- a/net/honeyd/files/patch-config.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- config.c.orig Thu Apr 14 16:07:26 2005
-+++ config.c Thu Apr 14 14:55:34 2005
-@@ -838,7 +838,7 @@
- IP_PROTO_TCP, src.addr_ip, dst.addr_ip);
- ip_checksum(pkt, iplen);
-
-- honeyd_recv_cb(&inter, &pkthdr, pkt);
-+ honeyd_recv_cb((u_char *)&inter, &pkthdr, pkt);
- }
- gettimeofday(&tv_end, NULL);
- timersub(&tv_end, &tv_start, &tv_end);
diff --git a/net/honeyd/files/patch-dhcpclient.c b/net/honeyd/files/patch-dhcpclient.c
index 95d38335a0cd..5cf499cfb36d 100644
--- a/net/honeyd/files/patch-dhcpclient.c
+++ b/net/honeyd/files/patch-dhcpclient.c
@@ -1,6 +1,6 @@
---- dhcpclient.c.orig Thu Apr 14 16:07:26 2005
-+++ dhcpclient.c Thu Apr 14 15:24:19 2005
-@@ -236,8 +236,8 @@
+--- dhcpclient.c.orig Thu Apr 20 08:23:52 2006
++++ dhcpclient.c Thu Apr 20 08:24:15 2006
+@@ -211,8 +211,8 @@
{
struct dhcpclient_req *req = tmpl->dhcp_req;
struct dhcp_msg *msg = (struct dhcp_msg *)buf;
@@ -11,23 +11,3 @@
short replyreq = 0, ack = 0, done = 0;
struct netconf nc;
struct addr *which = NULL, ipmask;
-@@ -472,7 +472,8 @@
-
- memset(buf, 0, sizeof(buf));
-
-- eth = (struct eth_hdr *)p = buf;
-+ p = buf;
-+ eth = (struct eth_hdr *)p;
- eth_pack_hdr(eth, ETH_ADDR_BROADCAST, req->ea, ETH_TYPE_IP);
-
- restlen -= ETH_HDR_LEN;
-@@ -524,7 +525,8 @@
-
- memset(buf, 0, sizeof(buf));
-
-- eth = (struct eth_hdr *)p = buf;
-+ p = buf;
-+ eth = (struct eth_hdr *)p;
- eth_pack_hdr(eth, req->server_ea, req->ea, ETH_TYPE_IP);
-
- restlen -= ETH_HDR_LEN;
diff --git a/net/honeyd/files/patch-honeyd.h b/net/honeyd/files/patch-honeyd.h
deleted file mode 100644
index 57eab22b6c11..000000000000
--- a/net/honeyd/files/patch-honeyd.h
+++ /dev/null
@@ -1,20 +0,0 @@
---- honeyd.h.orig Thu Apr 14 16:07:26 2005
-+++ honeyd.h Thu Apr 14 14:30:27 2005
-@@ -32,6 +32,8 @@
- #ifndef _HONEYD_H_
- #define _HONEYD_H_
-
-+#include <pcap.h>
-+
- #define PIDFILE "/var/run/honeyd.pid"
-
- #define TCP_DEFAULT_SIZE 512
-@@ -300,6 +302,8 @@
- char *honeyd_contoa(const struct tuple *);
-
- void honeyd_input(const struct interface *, struct ip_hdr *, u_short);
-+
-+void honeyd_recv_cb(u_char *, const struct pcap_pkthdr *, const u_char *);
-
- /* Command prototypes for services */
- void cmd_droppriv(uid_t, gid_t);
diff --git a/net/honeyd/files/patch-lex.c b/net/honeyd/files/patch-lex.c
deleted file mode 100644
index 90dd070ddb54..000000000000
--- a/net/honeyd/files/patch-lex.c
+++ /dev/null
@@ -1,74 +0,0 @@
---- lex.c.orig Thu Apr 14 16:07:26 2005
-+++ lex.c Thu Apr 14 14:48:11 2005
-@@ -153,8 +153,6 @@
- } \
- while ( 0 )
-
--#define unput(c) yyunput( c, yytext_ptr )
--
- /* The following is because we cannot portably get our hands on size_t
- * (without autoconf's help, which isn't available because we want
- * flex-generated scanners to compile on their own).
-@@ -657,10 +655,6 @@
- #endif
- #endif
-
--#ifndef YY_NO_UNPUT
--static void yyunput YY_PROTO(( int c, char *buf_ptr ));
--#endif
--
- #ifndef yytext_ptr
- static void yy_flex_strncpy YY_PROTO(( char *, yyconst char *, int ));
- #endif
-@@ -1662,51 +1656,6 @@
-
- return yy_is_jam ? 0 : yy_current_state;
- }
--
--
--#ifndef YY_NO_UNPUT
--#ifdef YY_USE_PROTOS
--static void yyunput( int c, register char *yy_bp )
--#else
--static void yyunput( c, yy_bp )
--int c;
--register char *yy_bp;
--#endif
-- {
-- register char *yy_cp = yy_c_buf_p;
--
-- /* undo effects of setting up yytext */
-- *yy_cp = yy_hold_char;
--
-- if ( yy_cp < yy_current_buffer->yy_ch_buf + 2 )
-- { /* need to shift things up to make room */
-- /* +2 for EOB chars. */
-- register int number_to_move = yy_n_chars + 2;
-- register char *dest = &yy_current_buffer->yy_ch_buf[
-- yy_current_buffer->yy_buf_size + 2];
-- register char *source =
-- &yy_current_buffer->yy_ch_buf[number_to_move];
--
-- while ( source > yy_current_buffer->yy_ch_buf )
-- *--dest = *--source;
--
-- yy_cp += (int) (dest - source);
-- yy_bp += (int) (dest - source);
-- yy_current_buffer->yy_n_chars =
-- yy_n_chars = yy_current_buffer->yy_buf_size;
--
-- if ( yy_cp < yy_current_buffer->yy_ch_buf + 2 )
-- YY_FATAL_ERROR( "flex scanner push-back overflow" );
-- }
--
-- *--yy_cp = (char) c;
--
--
-- yytext_ptr = yy_bp;
-- yy_hold_char = *yy_cp;
-- yy_c_buf_p = yy_cp;
-- }
--#endif /* ifndef YY_NO_UNPUT */
-
-
- #ifdef __cplusplus
diff --git a/net/honeyd/files/patch-rrdtool.c b/net/honeyd/files/patch-rrdtool.c
deleted file mode 100644
index 8e0f246c2021..000000000000
--- a/net/honeyd/files/patch-rrdtool.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- rrdtool.c.orig Thu Apr 14 16:07:26 2005
-+++ rrdtool.c Thu Apr 14 15:31:15 2005
-@@ -444,7 +444,7 @@
- int
- rrdtool_fork(struct rrdtool_drv *drv)
- {
-- char *argv[3];
-+ const char *argv[3];
- int pair[2];
- sigset_t sigmask;
-
-@@ -485,7 +485,7 @@
-
- close(pair[1]);
-
-- if (execvp(drv->bin_path, argv) == -1)
-+ if (execvp(drv->bin_path, (char *const *)argv) == -1)
- err(1, "%s: execv(%s)", __func__, drv->bin_path);
-
- /* NOT REACHED */
diff --git a/net/honeyd/pkg-plist b/net/honeyd/pkg-plist
index 8427bce38e54..5bfd2651acf3 100644
--- a/net/honeyd/pkg-plist
+++ b/net/honeyd/pkg-plist
@@ -1,40 +1,43 @@
bin/honeyd
bin/honeydctl
+bin/honeydstats
include/honeyd/debug.h
include/honeyd/hooks.h
include/honeyd/plugins.h
include/honeyd/plugins_config.h
lib/honeyd/libhoneyd.so
-share/honeyd/README
-share/honeyd/config.ethernet
-share/honeyd/config.sample
-share/honeyd/nmap.assoc
-share/honeyd/nmap.prints
-share/honeyd/pf.os
-share/honeyd/webserver/htdocs/config.py
-share/honeyd/webserver/htdocs/graphs/traffic_daily.gif
-share/honeyd/webserver/htdocs/graphs/traffic_hourly.gif
-share/honeyd/webserver/htdocs/images/add.gif
-share/honeyd/webserver/htdocs/images/arrow_down.gif
-share/honeyd/webserver/htdocs/images/arrow_right.gif
-share/honeyd/webserver/htdocs/images/delete.gif
-share/honeyd/webserver/htdocs/images/edit.gif
-share/honeyd/webserver/htdocs/images/google_logo.gif
-share/honeyd/webserver/htdocs/images/logo.gif
-share/honeyd/webserver/htdocs/index.py
-share/honeyd/webserver/htdocs/styles/layout.css
-share/honeyd/webserver/htdocs/templates/config_ip.tmpl
-share/honeyd/webserver/htdocs/templates/inc/footer.tmpl
-share/honeyd/webserver/htdocs/templates/inc/header.tmpl
-share/honeyd/webserver/htdocs/templates/inc/main.tmpl
-share/honeyd/webserver/htdocs/templates/inc/nav.tmpl
-share/honeyd/webserver/htdocs/templates/index.tmpl
-share/honeyd/webserver/htdocs/templates/status_connections.tmpl
-share/honeyd/webserver/htdocs/templates/status_stats.tmpl
-share/honeyd/webserver/htmltmpl.py
-share/honeyd/webserver/server.py
-share/honeyd/webserver/support.py
-share/honeyd/xprobe2.conf
+%%DATADIR%%/README
+%%DATADIR%%/config.ethernet
+%%DATADIR%%/config.sample
+%%DATADIR%%/nmap.assoc
+%%DATADIR%%/nmap.prints
+%%DATADIR%%/pf.os
+%%DATADIR%%/proxy
+%%DATADIR%%/smtp
+%%DATADIR%%/webserver/htdocs/config.py
+%%DATADIR%%/webserver/htdocs/graphs/traffic_daily.gif
+%%DATADIR%%/webserver/htdocs/graphs/traffic_hourly.gif
+%%DATADIR%%/webserver/htdocs/images/add.gif
+%%DATADIR%%/webserver/htdocs/images/arrow_down.gif
+%%DATADIR%%/webserver/htdocs/images/arrow_right.gif
+%%DATADIR%%/webserver/htdocs/images/delete.gif
+%%DATADIR%%/webserver/htdocs/images/edit.gif
+%%DATADIR%%/webserver/htdocs/images/google_logo.gif
+%%DATADIR%%/webserver/htdocs/images/logo.gif
+%%DATADIR%%/webserver/htdocs/index.py
+%%DATADIR%%/webserver/htdocs/styles/layout.css
+%%DATADIR%%/webserver/htdocs/templates/config_ip.tmpl
+%%DATADIR%%/webserver/htdocs/templates/inc/footer.tmpl
+%%DATADIR%%/webserver/htdocs/templates/inc/header.tmpl
+%%DATADIR%%/webserver/htdocs/templates/inc/main.tmpl
+%%DATADIR%%/webserver/htdocs/templates/inc/nav.tmpl
+%%DATADIR%%/webserver/htdocs/templates/index.tmpl
+%%DATADIR%%/webserver/htdocs/templates/status_connections.tmpl
+%%DATADIR%%/webserver/htdocs/templates/status_stats.tmpl
+%%DATADIR%%/webserver/htmltmpl.py
+%%DATADIR%%/webserver/server.py
+%%DATADIR%%/webserver/support.py
+%%DATADIR%%/xprobe2.conf
%%DATADIR%%/scripts/snmp/README
%%DATADIR%%/scripts/snmp/buildSNMPConfig.pl
%%DATADIR%%/scripts/snmp/fake-snmp.pl