aboutsummaryrefslogtreecommitdiffstats
path: root/net/howl
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-01-30 12:03:36 +0800
committermarcus <marcus@FreeBSD.org>2005-01-30 12:03:36 +0800
commitaa536795f49eda163aa51af9a44daf5a5c1e72c8 (patch)
tree5224edfb0078d3521b780e39843f8ebd0ac2f46d /net/howl
parentfd666021dca29ab1176e03c13d195de15fbe793f (diff)
downloadfreebsd-ports-gnome-aa536795f49eda163aa51af9a44daf5a5c1e72c8.tar.gz
freebsd-ports-gnome-aa536795f49eda163aa51af9a44daf5a5c1e72c8.tar.zst
freebsd-ports-gnome-aa536795f49eda163aa51af9a44daf5a5c1e72c8.zip
* Update to 0.9.10
* Add an rcNG script for starting mDNSResponder * Assume maintainership Approved by: Paul Dlug <paul@aps.org> (previous maintainer)
Diffstat (limited to 'net/howl')
-rw-r--r--net/howl/Makefile23
-rw-r--r--net/howl/distinfo4
-rw-r--r--net/howl/files/mdnsresponder.sh34
-rw-r--r--net/howl/pkg-plist1
4 files changed, 50 insertions, 12 deletions
diff --git a/net/howl/Makefile b/net/howl/Makefile
index fae96a4d84a6..1f61b91eb741 100644
--- a/net/howl/Makefile
+++ b/net/howl/Makefile
@@ -5,17 +5,17 @@
#
PORTNAME= howl
-PORTVERSION= 0.9.8
-PORTREVISION= 1
+PORTVERSION= 0.9.10
CATEGORIES?= net devel
MASTER_SITES= http://www.porchdogsoft.com/download/
-MAINTAINER= paul@aps.org
+MAINTAINER= marcus@FreeBSD.org
COMMENT= Zeroconf/Rendezvous implementation
USE_GMAKE= yes
USE_GNOME= gnometarget pkgconfig
USE_LIBTOOL_VER=15
+USE_RC_SUBR= yes
CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
CPPFLAGS+= ${PTHREAD_CFLAGS}
USE_REINPLACE= yes
@@ -24,16 +24,19 @@ INSTALLS_SHLIB= yes
MAN8= mDNSResponder.8
PLIST_SUB= VERSION="${PORTVERSION}"
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
-CPPFLAGS+= -D_LP64
-.endif
+RC_SCRIPTS_SUB= RC_SUBR=${RC_SUBR} PREFIX=${PREFIX}
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
+post-extract:
+ @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${FILESDIR}/mdnsresponder.sh > ${WRKSRC}/mdnsresponder.sh
+
post-patch:
@${REINPLACE_CMD} -e 's|-pthread||g' ${WRKSRC}/configure
-.include <bsd.port.post.mk>
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/mdnsresponder.sh \
+ ${PREFIX}/etc/rc.d/mdnsresponder.sh
+
+.include <bsd.port.mk>
diff --git a/net/howl/distinfo b/net/howl/distinfo
index aabb8821fdbb..ce415027dd1b 100644
--- a/net/howl/distinfo
+++ b/net/howl/distinfo
@@ -1,2 +1,2 @@
-MD5 (howl-0.9.8.tar.gz) = 92a1c18bf9b6817ec47fc7565166eb03
-SIZE (howl-0.9.8.tar.gz) = 540208
+MD5 (howl-0.9.10.tar.gz) = 444f2c1fe8eaf16d6822c01bfafba99b
+SIZE (howl-0.9.10.tar.gz) = 541004
diff --git a/net/howl/files/mdnsresponder.sh b/net/howl/files/mdnsresponder.sh
new file mode 100644
index 000000000000..1b94c1e60b5a
--- /dev/null
+++ b/net/howl/files/mdnsresponder.sh
@@ -0,0 +1,34 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: mdnsresponder
+# REQUIRE: DAEMON
+# KEYWORD: FreeBSD
+#
+# Howl's mDNSResponder, a Zeroconf (Rendezvous) service advertisement daemon.
+#
+
+mdnsresponder_enable=${mdnsresponder_enable-"NO"}
+mdnsresponder_flags=${mdnsresponder_flags-""}
+
+. %%RC_SUBR%%
+
+name=mdnsresponder
+rcvar=`set_rcvar`
+
+start_cmd=mdnsresponder_start
+stop_cmd=mdnsresponder_stop
+
+mdnsresponder_start() {
+ checkyesno mdnsresponder_enable && echo "Starting mDNSResponder." && \
+ %%PREFIX%%/bin/mDNSResponder ${mdnsresponder_flags}
+}
+
+mdnsresponder_stop() {
+ checkyesno mdnsresponder_enable && echo "Stopping mDNSResponder." && \
+ killall mDNSResponder
+}
+
+load_rc_config ${name}
+run_rc_command "$1"
diff --git a/net/howl/pkg-plist b/net/howl/pkg-plist
index f51d0bcf9a30..daa40307e8d4 100644
--- a/net/howl/pkg-plist
+++ b/net/howl/pkg-plist
@@ -3,6 +3,7 @@ bin/mDNSPublish
bin/mDNSQuery
bin/mDNSResolve
bin/mDNSResponder
+etc/rc.d/mdnsresponder.sh
include/howl/corby/buffer.h
include/howl/corby/channel.h
include/howl/corby/corby.h