aboutsummaryrefslogtreecommitdiffstats
path: root/net/http_ping
diff options
context:
space:
mode:
authordd <dd@FreeBSD.org>2001-08-12 02:55:26 +0800
committerdd <dd@FreeBSD.org>2001-08-12 02:55:26 +0800
commitae00dbcf36715fc6491480664c563ab1efaaa0e2 (patch)
tree1454ea6cd197ebe93e74836a09daf6cc028934ab /net/http_ping
parent4d32003a284c00e57499ce0068d0935de028d434 (diff)
downloadfreebsd-ports-gnome-ae00dbcf36715fc6491480664c563ab1efaaa0e2.tar.gz
freebsd-ports-gnome-ae00dbcf36715fc6491480664c563ab1efaaa0e2.tar.zst
freebsd-ports-gnome-ae00dbcf36715fc6491480664c563ab1efaaa0e2.zip
Add http_ping 20010709, a program that sends HTTP requests every few
seconds and times how long they take. Similar to ping(8).
Diffstat (limited to 'net/http_ping')
-rw-r--r--net/http_ping/Makefile24
-rw-r--r--net/http_ping/distinfo1
-rw-r--r--net/http_ping/pkg-comment1
-rw-r--r--net/http_ping/pkg-descr5
-rw-r--r--net/http_ping/pkg-plist1
5 files changed, 32 insertions, 0 deletions
diff --git a/net/http_ping/Makefile b/net/http_ping/Makefile
new file mode 100644
index 000000000000..6fd87ed09b44
--- /dev/null
+++ b/net/http_ping/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: http_ping
+# Date created: 11 August 2001
+# Whom: dd
+#
+# $FreeBSD$
+#
+
+PORTNAME= http_ping
+PORTVERSION= 20010709
+CATEGORIES= net
+MASTER_SITES= http://www.acme.com/software/http_ping/
+DISTNAME= ${PORTNAME}_09jul2001
+
+MAINTAINER= dd@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+MAN1= http_ping.1
+MANCOMPRESSED= no
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/http_ping ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/http_ping.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/net/http_ping/distinfo b/net/http_ping/distinfo
new file mode 100644
index 000000000000..047853ef4c38
--- /dev/null
+++ b/net/http_ping/distinfo
@@ -0,0 +1 @@
+MD5 (http_ping_09jul2001.tar.gz) = b8420963e72282691b11efc2983e4dd3
diff --git a/net/http_ping/pkg-comment b/net/http_ping/pkg-comment
new file mode 100644
index 000000000000..22a37c3d685e
--- /dev/null
+++ b/net/http_ping/pkg-comment
@@ -0,0 +1 @@
+Sends HTTP requests every few seconds and times how long they take
diff --git a/net/http_ping/pkg-descr b/net/http_ping/pkg-descr
new file mode 100644
index 000000000000..1be799db2246
--- /dev/null
+++ b/net/http_ping/pkg-descr
@@ -0,0 +1,5 @@
+http_ping is like the regular ping(8) command, except that it sends
+HTTP requests isntead of ICMP echo requests. I.e., it runs an HTTP
+fetch every few seconds, timing how long they take.
+
+WWW: http://www.acme.com/software/http_ping/
diff --git a/net/http_ping/pkg-plist b/net/http_ping/pkg-plist
new file mode 100644
index 000000000000..14b5306b00fd
--- /dev/null
+++ b/net/http_ping/pkg-plist
@@ -0,0 +1 @@
+bin/http_ping