aboutsummaryrefslogtreecommitdiffstats
path: root/net/httping
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2009-12-28 21:50:13 +0800
committerehaupt <ehaupt@FreeBSD.org>2009-12-28 21:50:13 +0800
commit907a0f5ce63437783a96bffebdc2ecd8c534e780 (patch)
tree30c34722b75192b52a2d6bcdceceb3998e180eae /net/httping
parentc2206697274dca6dd74fa5dc7762d385dfec759e (diff)
downloadfreebsd-ports-gnome-907a0f5ce63437783a96bffebdc2ecd8c534e780.tar.gz
freebsd-ports-gnome-907a0f5ce63437783a96bffebdc2ecd8c534e780.tar.zst
freebsd-ports-gnome-907a0f5ce63437783a96bffebdc2ecd8c534e780.zip
Update to 1.3.2
Diffstat (limited to 'net/httping')
-rw-r--r--net/httping/Makefile2
-rw-r--r--net/httping/distinfo6
-rw-r--r--net/httping/files/extra-patch-str.c6
-rw-r--r--net/httping/files/extra-patch-str.h4
-rw-r--r--net/httping/files/patch-Makefile23
5 files changed, 26 insertions, 15 deletions
diff --git a/net/httping/Makefile b/net/httping/Makefile
index 3693f2783211..45e7c9cb903e 100644
--- a/net/httping/Makefile
+++ b/net/httping/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= httping
-PORTVERSION= 1.3.1
+PORTVERSION= 1.3.2
CATEGORIES= net
MASTER_SITES= http://www.vanheusden.com/httping/ \
CRITICAL
diff --git a/net/httping/distinfo b/net/httping/distinfo
index 3a06962b2d9c..e222c937eae6 100644
--- a/net/httping/distinfo
+++ b/net/httping/distinfo
@@ -1,3 +1,3 @@
-MD5 (httping-1.3.1.tgz) = fb742d577d3e7a8ea75cf97f7eb802f2
-SHA256 (httping-1.3.1.tgz) = 0649d8b3aa200f03b77dcd69224928602e49abf248568338bed3c5748a94bcf2
-SIZE (httping-1.3.1.tgz) = 12873
+MD5 (httping-1.3.2.tgz) = 7cf1a8d822bcebddd3d5cca79f69cf07
+SHA256 (httping-1.3.2.tgz) = 0cc87b0176d5ff36bc64804fc574ed6a8e33ddafb88cec8a6ec9fcf9ba4a4823
+SIZE (httping-1.3.2.tgz) = 13724
diff --git a/net/httping/files/extra-patch-str.c b/net/httping/files/extra-patch-str.c
index eeb5b73c8980..b066992a2eb4 100644
--- a/net/httping/files/extra-patch-str.c
+++ b/net/httping/files/extra-patch-str.c
@@ -1,11 +1,11 @@
---- ./str.c.orig 2009-01-27 21:44:56.621283000 +0100
-+++ ./str.c 2009-01-27 21:45:24.936283000 +0100
+--- ./str.c.orig 2009-12-28 14:41:29.000000000 +0100
++++ ./str.c 2009-12-28 14:41:55.000000000 +0100
@@ -18,6 +18,7 @@
#include "mem.h"
#include "utils.h"
+/*
- #ifndef strndup
+ #ifndef _GNU_SOURCE
char *strndup(char *in, int size)
{
@@ -29,3 +30,4 @@
diff --git a/net/httping/files/extra-patch-str.h b/net/httping/files/extra-patch-str.h
index ac401b3d4d1b..0c850baed61d 100644
--- a/net/httping/files/extra-patch-str.h
+++ b/net/httping/files/extra-patch-str.h
@@ -1,5 +1,5 @@
---- ./str.h.orig 2009-01-27 21:42:34.920281000 +0100
-+++ ./str.h 2009-01-27 21:44:40.137282000 +0100
+--- ./str.h.orig 2009-12-28 14:41:13.000000000 +0100
++++ ./str.h 2009-12-28 14:41:23.000000000 +0100
@@ -15,6 +15,8 @@
#include <string.h>
diff --git a/net/httping/files/patch-Makefile b/net/httping/files/patch-Makefile
index c9a0fe4d3d57..8618577a585f 100644
--- a/net/httping/files/patch-Makefile
+++ b/net/httping/files/patch-Makefile
@@ -1,11 +1,22 @@
---- Makefile.orig 2009-08-04 10:55:36.000000000 +0200
-+++ Makefile 2009-08-04 10:55:46.000000000 +0200
-@@ -17,7 +17,7 @@
+--- ./Makefile.orig 2009-12-28 14:12:27.000000000 +0100
++++ ./Makefile 2009-12-28 14:41:02.000000000 +0100
+@@ -16,9 +16,7 @@
+
TARGET=httping
- WFLAGS=-Wall -W
+-WFLAGS=-Wall -W
-OFLAGS=-O2
-+OFLAGS?=-O2
- CFLAGS=$(WFLAGS) $(OFLAGS) -DVERSION=\"$(VERSION)\"
+-CFLAGS=$(WFLAGS) $(OFLAGS) -DVERSION=\"$(VERSION)\"
++CFLAGS+=-DVERSION=\"$(VERSION)\"
PACKAGE=$(TARGET)-$(VERSION)
+ PREFIX=/usr
+@@ -62,7 +60,7 @@
+ all: $(TARGET)
+
+ $(TARGET): $(OBJS)
+- $(CC) $(WFLAGS) $(OBJS) $(LDFLAGS) -o $(TARGET)
++ $(CC) $(OBJS) $(LDFLAGS) -o $(TARGET)
+ #
+ # Oh, blatant plug: http://keetweej.vanheusden.com/wishlist.html
+