aboutsummaryrefslogtreecommitdiffstats
path: root/net/httping
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2009-01-28 05:09:46 +0800
committerehaupt <ehaupt@FreeBSD.org>2009-01-28 05:09:46 +0800
commitf82b424d11cadb5d02378ddccdbc7cad8b33e568 (patch)
treec9c9592123156ed9973ae1d977dd251cf0713453 /net/httping
parentb7f279667cb76e1b3e8928bc440d1e192037e9c2 (diff)
downloadfreebsd-ports-gnome-f82b424d11cadb5d02378ddccdbc7cad8b33e568.tar.gz
freebsd-ports-gnome-f82b424d11cadb5d02378ddccdbc7cad8b33e568.tar.zst
freebsd-ports-gnome-f82b424d11cadb5d02378ddccdbc7cad8b33e568.zip
Fix build for OSVERSION after the strndup merge
Diffstat (limited to 'net/httping')
-rw-r--r--net/httping/Makefile12
-rw-r--r--net/httping/files/extra-patch-str.c15
-rw-r--r--net/httping/files/extra-patch-str.h11
3 files changed, 32 insertions, 6 deletions
diff --git a/net/httping/Makefile b/net/httping/Makefile
index 7f5a1fc7edbf..9921a0ae267e 100644
--- a/net/httping/Makefile
+++ b/net/httping/Makefile
@@ -18,14 +18,14 @@ COMMENT= A ping-like tool for HTTP requests
MAN1= httping.1
PLIST_FILES= bin/httping
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
-
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 800058
-BROKEN= does not build
+.if(${OSVERSION} >= 701101)
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-str.c ${FILESDIR}/extra-patch-str.h
.endif
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
+
.include <bsd.port.post.mk>
diff --git a/net/httping/files/extra-patch-str.c b/net/httping/files/extra-patch-str.c
new file mode 100644
index 000000000000..eeb5b73c8980
--- /dev/null
+++ b/net/httping/files/extra-patch-str.c
@@ -0,0 +1,15 @@
+--- ./str.c.orig 2009-01-27 21:44:56.621283000 +0100
++++ ./str.c 2009-01-27 21:45:24.936283000 +0100
+@@ -18,6 +18,7 @@
+ #include "mem.h"
+ #include "utils.h"
+
++/*
+ #ifndef strndup
+ char *strndup(char *in, int size)
+ {
+@@ -29,3 +30,4 @@
+ return out;
+ }
+ #endif
++*/
diff --git a/net/httping/files/extra-patch-str.h b/net/httping/files/extra-patch-str.h
new file mode 100644
index 000000000000..ac401b3d4d1b
--- /dev/null
+++ b/net/httping/files/extra-patch-str.h
@@ -0,0 +1,11 @@
+--- ./str.h.orig 2009-01-27 21:42:34.920281000 +0100
++++ ./str.h 2009-01-27 21:44:40.137282000 +0100
+@@ -15,6 +15,8 @@
+
+ #include <string.h>
+
++/*
+ #ifndef strndup
+ char *strndup(char *in, int size);
+ #endif
++*/