aboutsummaryrefslogtreecommitdiffstats
path: root/net/isc-dhcp3-server/Makefile
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2005-07-26 02:34:18 +0800
committersem <sem@FreeBSD.org>2005-07-26 02:34:18 +0800
commit9ac02d5e98a3e5167111ea79f0282ba1986f94c4 (patch)
tree818941d79c1e0521e9e45915b0185899c7809d18 /net/isc-dhcp3-server/Makefile
parent908687395f38fdf1109a29b137b87310af2f5a45 (diff)
downloadfreebsd-ports-gnome-9ac02d5e98a3e5167111ea79f0282ba1986f94c4.tar.gz
freebsd-ports-gnome-9ac02d5e98a3e5167111ea79f0282ba1986f94c4.tar.zst
freebsd-ports-gnome-9ac02d5e98a3e5167111ea79f0282ba1986f94c4.zip
* update the net/isc-dhcp3-* ports to v3.0.3
- this is a maintenance release - failover related bugs fixed - BOOTP related bugs fixed - DDNS related bugs fixed - manpage updates - small memory leak closed * changes to the port itself - better use of PATCH_SITES and PATCHFILES - added new OPTION: DHCP_SOCKETS + this offers the possibility to prefer sockets over /dev/bpf ( only useful for jail(8)ed environments where the bpf device is not available and therefore only utilized if DHCP_JAIL is set ) this addresses the PR ports/76820 PR: ports/84057 Submitted by: Joerg Pulz <Joerg.Pulz@frm2.tum.de> (maintainer)
Diffstat (limited to 'net/isc-dhcp3-server/Makefile')
-rw-r--r--net/isc-dhcp3-server/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/net/isc-dhcp3-server/Makefile b/net/isc-dhcp3-server/Makefile
index c536c48ed1ab..646175fafee8 100644
--- a/net/isc-dhcp3-server/Makefile
+++ b/net/isc-dhcp3-server/Makefile
@@ -7,8 +7,8 @@
#
PORTNAME= dhcp
-PORTVERSION= 3.0.2
-PORTREVISION= 8
+PORTVERSION= 3.0.3
+PORTREVISION= 0
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR= dhcp dhcp/dhcp-3.0-history
@@ -31,6 +31,7 @@ OPTIONS= INTERFACE_POLLING "interface polling support" on
.if ${SUBSYS} == server
OPTIONS= DHCP_PARANOIA "add -user, -group and -chroot options" on \
DHCP_JAIL "add -chroot and -jail options" on \
+ DHCP_SOCKETS "use sockets instead of /dev/bpf (jail-only)" off \
DHCP_LDAP "add experimental LDAP backend support" off \
DHCP_LDAP_SSL "support LDAP connection over SSL/TLS" on \
OPENSSL_BASE "use the base system OpenSSL (required by TLS)" on \
@@ -42,9 +43,9 @@ OPTIONS= DHCP_PARANOIA "add -user, -group and -chroot options" on \
.if ${SUBSYS} == server && defined(WITH_DHCP_LDAP)
# Based on patch from Brian Masney :
-PATCH_SITES= http://www.newwave.net/~masneyb/ \
- ftp://ftp.frm2.tum.de/pub/jpulz/FreeBSD/
-PATCHFILES= ${PORTNAME}-${RELEASE}${VERSION}${PATCHLEVEL}-ldap-patch
+PATCH_SITES= http://www.newwave.net/~masneyb/:ldap \
+ ftp://ftp.frm2.tum.de/pub/jpulz/FreeBSD/:ldap
+PATCHFILES= ${PORTNAME}-${RELEASE}${VERSION}${PATCHLEVEL}-ldap-patch:ldap
PATCH_DIST_STRIP= -p1
USE_PERL5_RUN= yes
@@ -59,9 +60,9 @@ USE_OPENSSL= yes
.if ${SUBSYS} == server && defined(WITH_DHCP_LQ)
# Based on patch from Dmitry Sukhodoev :
-PATCH_SITES= http://bingo.ru/~raven/FreeBSD/patches/ \
- ftp://ftp.frm2.tum.de/pub/jpulz/FreeBSD/
-PATCHFILES+= ${PORTNAME}-${RELEASE}${VERSION}${PATCHLEVEL}-dlq-patch
+PATCH_SITES+= http://bingo.ru/~raven/FreeBSD/patches/:dlq \
+ ftp://ftp.frm2.tum.de/pub/jpulz/FreeBSD/:dlq
+PATCHFILES+= ${PORTNAME}-${RELEASE}${VERSION}${PATCHLEVEL}-dlq-patch:dlq
.endif
# Global variables
@@ -225,6 +226,9 @@ patch-site-conf:
.endif
.if !defined(WITHOUT_DHCP_JAIL)
@${ECHO_CMD} CFLAGS += -DJAIL >> ${WRKSRC}/site.conf
+.if defined(WITH_DHCP_SOCKETS)
+ @${ECHO_CMD} CFLAGS += -DUSE_SOCKETS >> ${WRKSRC}/site.conf
+.endif
.endif
.if defined(WITH_DHCP_LDAP)
@${ECHO_CMD} CFLAGS += -I${LOCALBASE}/include >> ${WRKSRC}/site.conf