aboutsummaryrefslogtreecommitdiffstats
path: root/net/isc-dhcp44-server
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2018-03-03 00:50:46 +0800
committerzi <zi@FreeBSD.org>2018-03-03 00:50:46 +0800
commit869a94d71936f24748ae4ef6669dd42046e6fdfa (patch)
tree6a827f4e62df2fbf1587382963c44e1aa0474b70 /net/isc-dhcp44-server
parent1e60c24f6fc95349169acaef0fe62d6c7196c335 (diff)
downloadfreebsd-ports-gnome-869a94d71936f24748ae4ef6669dd42046e6fdfa.tar.gz
freebsd-ports-gnome-869a94d71936f24748ae4ef6669dd42046e6fdfa.tar.zst
freebsd-ports-gnome-869a94d71936f24748ae4ef6669dd42046e6fdfa.zip
- Update to 4.4.1 [1]
- Convert to new OPTIONS framework - Add OPTION for enabling binary lease file support PR: 191088 [1] Submitted by: Chip Cuccio <chip.cuccio@gmail.com> [1]
Diffstat (limited to 'net/isc-dhcp44-server')
-rw-r--r--net/isc-dhcp44-server/Makefile70
-rw-r--r--net/isc-dhcp44-server/distinfo6
-rw-r--r--net/isc-dhcp44-server/files/isc-dhcpd.in2
3 files changed, 29 insertions, 49 deletions
diff --git a/net/isc-dhcp44-server/Makefile b/net/isc-dhcp44-server/Makefile
index dacf432d3291..d9588fafdaac 100644
--- a/net/isc-dhcp44-server/Makefile
+++ b/net/isc-dhcp44-server/Makefile
@@ -2,14 +2,15 @@
# $FreeBSD$
PORTNAME= dhcp
-PORTVERSION= 4.4.0b1
+ISCVERSION= 4.4.1
+PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
PORTREVISION= ${DHCP_PORTREVISION}
CATEGORIES= net
MASTER_SITES= ISC/${PORTNAME}/${PORTVERSION:S/P/-P/g} \
ZI
PKGNAMEPREFIX= isc-
PKGNAMESUFFIX= 44-${SUBSYS}
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/P/-P/g}
+DISTNAME= ${PORTNAME}-${ISCVERSION}
MAINTAINER= zi@FreeBSD.org
COMMENT?= ISC Dynamic Host Configuration Protocol server
@@ -18,23 +19,24 @@ LICENSE= MPL20
USES= gmake
-FORBIDDEN= Serious flaw in 4.4.0 dhcpd, please wait for 4.4.1
-
-PORTREVISION_SERVER= 1
+PORTREVISION_SERVER= 0
PORTREVISION_CLIENT= 0
PORTREVISION_RELAY= 0
SUBSYS?= server
OPTIONS_DEFINE= IPV6
+OPTIONS_SUB= yes
.if ${SUBSYS} == server
-OPTIONS_DEFINE+= PARANOIA LDAP LDAP_SSL BIND_SYMBOLS DHCP4O6
+OPTIONS_DEFINE+= PARANOIA LDAP LDAP_SSL BIND_SYMBOLS DHCP4O6 \
+ BINLEASES
OPTIONS_DEFAULT+= PARANOIA LDAP_SSL
DHCP4O6_DESC= Enable DHCPv4-over-DHCPv6 (TSV)
PARANOIA_DESC= Enable support for chroot
LDAP_SSL_DESC= Support LDAP over SSL/TLS
BIND_SYMBOLS_DESC= Enable BIND internal symbol table
+BINLEASES_DESC= Enable support for binary insertion of leases
.endif
# PORTREVISION and CONFLICTS handling
@@ -60,8 +62,6 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -D_PATH_DHCLIENT_SCRIPT='\"${PREFIX}/sbin/dhclient-script\"' -D_PATH_DHCLIENT_CONF='\"${PREFIX}/etc/dhclient.conf\"' -D_PATH_DHCPD_CONF='\"${PREFIX}/etc/dhcpd.conf\"'
SCRIPTS_ENV+= PKG_PREFIX=${PREFIX}
-.include <bsd.port.options.mk>
-
.if ${SUBSYS} == server
CONFIGURE_ARGS+=--localstatedir=/var
CFLAGS+= -fPIC
@@ -87,16 +87,23 @@ REINPLACE_SUB= PREFIX="${PREFIX}"
PKGMESSAGE_SUB= PREFIX="${PREFIX}" MAN1PREFIX="${MAN1PREFIX}" \
DOCSDIR="${DOCSDIR}"
-.if ${PORT_OPTIONS:MPARANOIA}
-CONFIGURE_ARGS+=--enable-paranoia --enable-early-chroot
-SUB_LIST+= PARANOIA="yes"
-.else
-SUB_LIST+= PARANOIA="no"
-.endif
+BINLEASES_CONFIGURE_ENABLE= binary-leases
+PARANOIA_CONFIGURE_ENABLE= paranoia early-chroot
+PARANOIA_CONFIGURE_VARS= PARANOIAOPT="yes"
+PARANOIA_CONFIGURE_VARS_OFF= PARANOIAOPT="no"
+LDAP_CONFIGURE_WITH= ldap ldapcrypto
+LDAP_USE= OPENLDAP
+LDAP_USES= shebangfix
+LDAP_SSL_CONFIGURE_WITH= ldapcrypto
+LDAP_SSL_USES= ssl
+LDAP_SSL_VARS= LIBS+=-lssl
+IPV6_CONFIGURE_ENABLE= dhcpv6
+DHCP4O6_CONFIGURE_ENABLE= dhcpv4o6
+BIND_SYMBOLS_USES= perl5
+
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MLDAP}
-CONFIGURE_ARGS+=--with-ldap --with-ldapcrypto
-USE_OPENLDAP= yes
LDAP_SCRIPT= ${WRKSRC}/contrib/ldap/dhcpd-conf-to-ldap
LDAP_SCHEMA= ${WRKSRC}/contrib/ldap/dhcp.schema
LDAP_README= ${WRKSRC}/contrib/ldap/README.ldap
@@ -104,38 +111,11 @@ CPPFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
LIBS+= -L${LOCALBASE}/lib
PORTDOCS+= README.ldap
PLIST_SUB+= SCHEMA_DIR="${SCHEMA_DIR:S,^${PREFIX}/,,}" LDAP=""
-USES+= shebangfix
SHEBANG_FILES= contrib/ldap/dhcpd-conf-to-ldap
-.else
-PLIST_SUB+= LDAP="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MLDAP_SSL} && ${PORT_OPTIONS:MLDAP}
-USES+= ssl
-CONFIGURE_ARGS+=--with-ldapcrypto
-LIBS+= -lssl
-.endif
-
-.if ${PORT_OPTIONS:MIPV6}
-CONFIGURE_ARGS+=--enable-dhcpv6
-PLIST_SUB+= IPV6=""
-.else
-CONFIGURE_ARGS+=--disable-dhcpv6
-PLIST_SUB+= IPV6="@comment "
.endif
-.if ${PORT_OPTIONS:MDHCP4O6}
-CONFIGURE_ARGS+=--enable-dhcpv4o6
-PLIST_SUB+= DHCP4O6=""
-.else
-CONFIGURE_ARGS+=--disable-dhcpv4o6
-PLIST_SUB+= DHCP4O6="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MBIND_SYMBOLS}
-USES+= perl5
-.else
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-bind_Makefile.in
+.if empty(PORT_OPTIONS:MBIND_SYMBOLS)
+EXTRA_PATCHES+=${PATCHDIR}/extra-patch-bind_Makefile.in
.endif
post-patch:
diff --git a/net/isc-dhcp44-server/distinfo b/net/isc-dhcp44-server/distinfo
index 5f3926ce81f1..50bb9ffc4614 100644
--- a/net/isc-dhcp44-server/distinfo
+++ b/net/isc-dhcp44-server/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1515530294
-SHA256 (dhcp-4.4.0b1.tar.gz) = 9bb9fcef57e31660d43c83481d60cfa16fd2ad99fd7bbe7f0ae2ca81406a80c2
-SIZE (dhcp-4.4.0b1.tar.gz) = 11151721
+TIMESTAMP = 1520005726
+SHA256 (dhcp-4.4.1.tar.gz) = 2a22508922ab367b4af4664a0472dc220cc9603482cf3c16d9aff14f3a76b608
+SIZE (dhcp-4.4.1.tar.gz) = 11164378
diff --git a/net/isc-dhcp44-server/files/isc-dhcpd.in b/net/isc-dhcp44-server/files/isc-dhcpd.in
index 4656dc0cafc4..5e2c97dee2a8 100644
--- a/net/isc-dhcp44-server/files/isc-dhcpd.in
+++ b/net/isc-dhcp44-server/files/isc-dhcpd.in
@@ -35,7 +35,7 @@ esac
name="${name:-dhcpd}" ;
name=${name##*/isc-}
-paranoia=%%PARANOIA%% # compiled in paranoia?
+paranoia=%%PARANOIAOPT%% # compiled in paranoia?
load_rc_config ${name}