aboutsummaryrefslogtreecommitdiffstats
path: root/net/jwhois/Makefile
diff options
context:
space:
mode:
authormatusita <matusita@FreeBSD.org>2002-03-16 00:53:34 +0800
committermatusita <matusita@FreeBSD.org>2002-03-16 00:53:34 +0800
commit70ffc9e3552b3229459441fc080fd2ccf9550c92 (patch)
tree1c4671a373557d33e630e60bc88048117ae88eaf /net/jwhois/Makefile
parentcbee8b90fa082fc5e16d24ce8fdfb3edb77b95f5 (diff)
downloadfreebsd-ports-gnome-70ffc9e3552b3229459441fc080fd2ccf9550c92.tar.gz
freebsd-ports-gnome-70ffc9e3552b3229459441fc080fd2ccf9550c92.tar.zst
freebsd-ports-gnome-70ffc9e3552b3229459441fc080fd2ccf9550c92.zip
Fix the problem that the jwhois datacache mechanism is not working properly.
In src/Makefile.am rev 1.18, install-exec-hook: is disappeared (I dunno why, CVS commit log doesn't answer my question). As a result, jwhois binary is not chgrp(1)ed, so do it in Makefile. pkg-plist should be fixed to include (empty) datacache directory (that's long standing bug since the beginning of this port, sorry).
Diffstat (limited to 'net/jwhois/Makefile')
-rw-r--r--net/jwhois/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/net/jwhois/Makefile b/net/jwhois/Makefile
index 4bec7c033bff..3c186e4a22b8 100644
--- a/net/jwhois/Makefile
+++ b/net/jwhois/Makefile
@@ -29,6 +29,8 @@ post-install:
${MKDIR} ${PREFIX}/var/jwhois
${CHOWN} :nogroup ${PREFIX}/var/jwhois
${CHMOD} g+w ${PREFIX}/var/jwhois
+ ${CHOWN} :nogroup ${PREFIX}/bin/jwhois
+ ${CHMOD} g+s ${PREFIX}/bin/jwhois
${INSTALL_DATA} ${WRKSRC}/example/jwhois.conf ${PREFIX}/etc/jwhois.conf.sample
if [ ! -f ${PREFIX}/etc/jwhois.conf ]; then ${INSTALL_DATA} ${PREFIX}/etc/jwhois.conf.sample ${PREFIX}/etc/jwhois.conf; fi