aboutsummaryrefslogtreecommitdiffstats
path: root/net/jwhois/Makefile
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2000-07-27 13:40:55 +0800
committerkuriyama <kuriyama@FreeBSD.org>2000-07-27 13:40:55 +0800
commit954654d3f3b5cbe484d3dbbf33fdf2e3999d358f (patch)
treec4d92cde358e224d53d6cb613c3e1a53b8d61e65 /net/jwhois/Makefile
parentf72d940416ff8594c65499525796d6625b9d03c0 (diff)
downloadfreebsd-ports-gnome-954654d3f3b5cbe484d3dbbf33fdf2e3999d358f.tar.gz
freebsd-ports-gnome-954654d3f3b5cbe484d3dbbf33fdf2e3999d358f.tar.zst
freebsd-ports-gnome-954654d3f3b5cbe484d3dbbf33fdf2e3999d358f.zip
Yet another whois client.
Submitted by: Makoto MATSUSHITA <matusita@jp.freebsd.org> PR: ports/20135
Diffstat (limited to 'net/jwhois/Makefile')
-rw-r--r--net/jwhois/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/net/jwhois/Makefile b/net/jwhois/Makefile
new file mode 100644
index 000000000000..58964110d2bf
--- /dev/null
+++ b/net/jwhois/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: jwhois
+# Date created: 15 Jul 2000
+# Whom: matusita@jp.FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= jwhois
+PORTVERSION= 2.4.1
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= jwhois
+
+MAINTAINER= matusita@jp.FreeBSD.org
+
+LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --localstatedir=${PREFIX}/var/jwhois
+USE_GMAKE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include" LDFLAGS="-L${PREFIX}/lib"
+
+INSTALL_TARGET= install-strip
+
+MAN1= jwhois.1
+
+post-install:
+ ${MKDIR} ${PREFIX}/var/jwhois
+ ${CHOWN} :nogroup ${PREFIX}/var/jwhois
+ ${CHMOD} g+w ${PREFIX}/var/jwhois
+ ${INSTALL_DATA} ${WRKSRC}/example/jwhois.conf ${PREFIX}/etc
+
+.include <bsd.port.mk>