aboutsummaryrefslogtreecommitdiffstats
path: root/net/jwhois/Makefile
diff options
context:
space:
mode:
authormatusita <matusita@FreeBSD.org>2005-03-08 20:41:26 +0800
committermatusita <matusita@FreeBSD.org>2005-03-08 20:41:26 +0800
commita60422d258770004725be72328e46c3ac39c5a31 (patch)
treef658aa0eaa2a1715270c1201c98db02259d480f9 /net/jwhois/Makefile
parente56f485fad43818df430f682037a632878ccc73d (diff)
downloadfreebsd-ports-gnome-a60422d258770004725be72328e46c3ac39c5a31.tar.gz
freebsd-ports-gnome-a60422d258770004725be72328e46c3ac39c5a31.tar.zst
freebsd-ports-gnome-a60422d258770004725be72328e46c3ac39c5a31.zip
Install the latest jwhois.conf file that comes from jwhois CVS repository.
- fetch jwhois.conf rev 1.106[1] via viewcvs. - put it to files/jwhois.conf - make a typo fix (s/whios/whois/g;) to files/jwhois.conf (this change will be submitted to original author very soon) [1] http://savannah.gnu.org/cgi-bin/viewcvs/jwhois/jwhois/example/jwhois.conf This commit makes content change, so bump PORTREVISION. Enjoy. Suggested by: Shinichiro Komatsu (via ReichaNet channel)
Diffstat (limited to 'net/jwhois/Makefile')
-rw-r--r--net/jwhois/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/net/jwhois/Makefile b/net/jwhois/Makefile
index cd6451daf9b7..e7c1a17d6d54 100644
--- a/net/jwhois/Makefile
+++ b/net/jwhois/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jwhois
PORTVERSION= 3.2.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= jwhois
@@ -33,13 +33,21 @@ MANLANG= "" sv
MAN1= jwhois.1
INFO= jwhois
+.include <bsd.port.pre.mk>
+
+.if exists(${FILESDIR}/jwhois.conf)
+JWHOIS_CONF_SRC=${FILESDIR}/jwhois.conf
+.else
+JWHOIS_CONF_SRC=${WRKSRC}/example/jwhois.conf
+.endif
+
post-install:
${MKDIR} ${PREFIX}/var/jwhois
${CHOWN} :nogroup ${PREFIX}/var/jwhois
${CHMOD} g+w ${PREFIX}/var/jwhois
${CHOWN} :nogroup ${PREFIX}/bin/jwhois
${CHMOD} g+s ${PREFIX}/bin/jwhois
- ${INSTALL_DATA} ${WRKSRC}/example/jwhois.conf ${PREFIX}/etc/jwhois.conf.sample
+ ${INSTALL_DATA} ${JWHOIS_CONF_SRC} ${PREFIX}/etc/jwhois.conf.sample
if [ ! -f ${PREFIX}/etc/jwhois.conf ]; then ${INSTALL_DATA} ${PREFIX}/etc/jwhois.conf.sample ${PREFIX}/etc/jwhois.conf; fi
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>