aboutsummaryrefslogtreecommitdiffstats
path: root/net/kdenetwork4
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2009-02-09 17:29:31 +0800
committermakc <makc@FreeBSD.org>2009-02-09 17:29:31 +0800
commit2b2e095c5e271d4a2d069f4d117322fbc70cf1b2 (patch)
treee1b466baebdf94ddf0e91ab15e3ea639a0b60685 /net/kdenetwork4
parent84f177df4b25e296ab4e88ac43b3003773c26aab (diff)
downloadfreebsd-ports-gnome-2b2e095c5e271d4a2d069f4d117322fbc70cf1b2.tar.gz
freebsd-ports-gnome-2b2e095c5e271d4a2d069f4d117322fbc70cf1b2.tar.zst
freebsd-ports-gnome-2b2e095c5e271d4a2d069f4d117322fbc70cf1b2.zip
Add missing patch to fix build (noticed by beech)
Diffstat (limited to 'net/kdenetwork4')
-rw-r--r--net/kdenetwork4/files/patch-kopete__plugins__otr__CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/net/kdenetwork4/files/patch-kopete__plugins__otr__CMakeLists.txt b/net/kdenetwork4/files/patch-kopete__plugins__otr__CMakeLists.txt
new file mode 100644
index 000000000000..49aad1d2a5ce
--- /dev/null
+++ b/net/kdenetwork4/files/patch-kopete__plugins__otr__CMakeLists.txt
@@ -0,0 +1,29 @@
+--- ../kopete/plugins/otr/CMakeLists.txt.orig 2008-10-01 16:20:37.000000000 +0000
++++ ../kopete/plugins/otr/CMakeLists.txt 2009-01-28 23:21:50.000000000 +0000
+@@ -10,7 +10,7 @@
+
+ kde4_add_plugin(kopete_otr ${kopete_otr_PART_SRCS})
+
+-target_link_libraries(kopete_otr ${KDE4_KDEUI_LIBS} kopete kopete_otr_shared otr)
++target_link_libraries(kopete_otr ${KDE4_KDEUI_LIBS} kopete kopete_otr_shared ${LIBOTR_LIBRARY})
+
+ install(TARGETS kopete_otr DESTINATION ${PLUGIN_INSTALL_DIR})
+
+@@ -24,7 +24,7 @@
+
+ kde4_add_plugin(kcm_kopete_otr ${kcm_kopete_otr_PART_SRCS})
+
+-target_link_libraries(kcm_kopete_otr ${KDE4_KDEUI_LIBS} kopete kopete_otr_shared otr)
++target_link_libraries(kcm_kopete_otr ${KDE4_KDEUI_LIBS} kopete kopete_otr_shared ${LIBOTR_LIBRARY})
+
+ install(TARGETS kcm_kopete_otr DESTINATION ${PLUGIN_INSTALL_DIR})
+
+@@ -40,7 +40,7 @@
+
+ kde4_add_library(kopete_otr_shared SHARED ${kopete_otr_shared_LIB_SRCS})
+
+-target_link_libraries(kopete_otr_shared kopete ${KDE4_KIO_LIBS} ${KDE4_KDEUI_LIBS} otr)
++target_link_libraries(kopete_otr_shared kopete ${KDE4_KIO_LIBS} ${KDE4_KDEUI_LIBS} ${LIBOTR_LIBRARY})
+
+ set_target_properties(kopete_otr_shared PROPERTIES VERSION 1.0.0 SOVERSION 1)
+ install(TARGETS kopete_otr_shared ${INSTALL_TARGETS_DEFAULT_ARGS})