aboutsummaryrefslogtreecommitdiffstats
path: root/net/keepalived/files
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2005-09-09 03:55:01 +0800
committerclement <clement@FreeBSD.org>2005-09-09 03:55:01 +0800
commit549489b4ec03dccf474f5ad9d00afe703d608ac5 (patch)
treeb1edbf6e84e5fb3f4256104af8170d2dfb8b52e9 /net/keepalived/files
parent0e84d684fbe13434ba15d58a2161fa122d41c66e (diff)
downloadfreebsd-ports-gnome-549489b4ec03dccf474f5ad9d00afe703d608ac5.tar.gz
freebsd-ports-gnome-549489b4ec03dccf474f5ad9d00afe703d608ac5.tar.zst
freebsd-ports-gnome-549489b4ec03dccf474f5ad9d00afe703d608ac5.zip
- Add a FreeBSD port of keepalived daemon, based on version 1.1.11
Keepalived is an ipvs wrapper and a service health-checker. FreeBSD port does not support keepalived VRRP stack, but it can be easily replaced by carp interfaces. WWW: http://www.keepalived.org/
Diffstat (limited to 'net/keepalived/files')
-rw-r--r--net/keepalived/files/keepalived.sh.in33
-rw-r--r--net/keepalived/files/patch-keepalived__Makefile.in25
2 files changed, 58 insertions, 0 deletions
diff --git a/net/keepalived/files/keepalived.sh.in b/net/keepalived/files/keepalived.sh.in
new file mode 100644
index 000000000000..7b931d26e749
--- /dev/null
+++ b/net/keepalived/files/keepalived.sh.in
@@ -0,0 +1,33 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: keepalived
+# REQUIRE: NETWORKING SERVERS
+# BEFORE: DAEMON
+# KEYWORD: FreeBSD shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable apache2:
+# apache2_keepalived (bool): Set to "NO" by default.
+# Set it to "YES" to enable keepalived
+# apache2_profiles (string): Undefined by default. Define here your profiles.
+
+. %%RC_SUBR%%
+
+name="keepalived"
+rcvar=`set_rcvar`
+
+command="%%PREFIX%%/sbin/keepalived"
+pidfile="/var/run/keepalived.pid"
+required_files=%%PREFIX%%/etc/keepalived/keepalived.conf
+
+[ -z "${keepalived_enable}" ] && keepalived_enable="NO"
+
+load_rc_config $name
+
+sig_reload=SIGHUP
+
+extra_commands="reload"
+run_rc_command "$1"
diff --git a/net/keepalived/files/patch-keepalived__Makefile.in b/net/keepalived/files/patch-keepalived__Makefile.in
new file mode 100644
index 000000000000..eff7630b3f86
--- /dev/null
+++ b/net/keepalived/files/patch-keepalived__Makefile.in
@@ -0,0 +1,25 @@
+--- keepalived/Makefile.in.orig Sat Aug 20 16:54:34 2005
++++ keepalived/Makefile.in Thu Sep 8 21:25:25 2005
+@@ -16,6 +16,7 @@
+ sysconfdir = @sysconfdir@
+ init_script = etc/init.d/keepalived.init
+ conf_file = etc/keepalived/keepalived.conf
++examplesdir = @prefix@/share/examples
+
+ CC = @CC@
+ STRIP = @STRIP@
+@@ -103,11 +104,9 @@
+ install:
+ install -d $(DESTDIR)$(sbindir)
+ install -m 700 $(BIN)/$(EXEC) $(DESTDIR)$(sbindir)/
+- install -d $(DESTDIR)$(sysconfdir)/init.d
+- install -m 755 $(init_script) $(DESTDIR)$(sysconfdir)/init.d/keepalived
+- install -d $(DESTDIR)$(sysconfdir)/keepalived/samples
+- install -m 644 $(conf_file) $(DESTDIR)$(sysconfdir)/keepalived/
+- install -m 644 ../doc/samples/* $(DESTDIR)$(sysconfdir)/keepalived/samples/
++ install -d $(DESTDIR)$(examplesdir)/keepalived/samples
++ install -m 644 $(conf_file) $(DESTDIR)$(examplesdir)/keepalived/
++ install -m 644 ../doc/samples/* $(DESTDIR)$(examplesdir)/keepalived/samples/
+ install -d $(DESTDIR)@mandir@/man/man5
+ install -d $(DESTDIR)@mandir@/man/man8
+ install -m 644 ../doc/man/man5/keepalived.conf.5 $(DESTDIR)@mandir@/man/man5