aboutsummaryrefslogtreecommitdiffstats
path: root/net/kmud
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-04-03 16:14:43 +0800
committerwill <will@FreeBSD.org>2001-04-03 16:14:43 +0800
commite282c995211fa7d389e4d3b437d0ff892d4d929b (patch)
treec8e1217a1b00314713ec60f3c0d07c11dc242116 /net/kmud
parenta4c43b9975be01621916750b073e7125e629feba (diff)
downloadfreebsd-ports-gnome-e282c995211fa7d389e4d3b437d0ff892d4d929b.tar.gz
freebsd-ports-gnome-e282c995211fa7d389e4d3b437d0ff892d4d929b.tar.zst
freebsd-ports-gnome-e282c995211fa7d389e4d3b437d0ff892d4d929b.zip
Overhaul QT/KDE support:
- bsd.port.mk update to use bsd.kde.mk for USE_{QT,KDE}* - Cleanup corresponding ports for bsd.kde.mk update. - Fix bsd.kde.mk: use correct kdelibs dependency, put qt at the bottom, introduce QT_NONSTANDARD variable for nonstandard configure setup. - Update KDE2 to 2.1.1. Two patches included in x11/kdelibs2 to fix the proxy authentication that was broken for 2.1.1. Remove old patches. - Potentially fix kdelibs build for alpha. - Fix qt-designer 2.3.0 build. - Ruby stuff left alone since it looks like black magic to me. Should still work w/ compat shims for older USE_QT[,2] style. Some others were also left alone for the same reason. Reviewed by: portmgr, ports (bsd.kde.mk+bsd.port.mk) Submitted by: David Faure <faure@kde.org> (proxy auth patches) Alex Zepeda <garbanzo@kde.org> (old patches removal)
Diffstat (limited to 'net/kmud')
-rw-r--r--net/kmud/Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/net/kmud/Makefile b/net/kmud/Makefile
index db65b8d5058d..49e192c2a71c 100644
--- a/net/kmud/Makefile
+++ b/net/kmud/Makefile
@@ -14,17 +14,13 @@ MASTER_SITE_SUBDIR= games/muds
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= kdecore.3:${PORTSDIR}/x11/kdelibs11
BUILD_DEPENDS= gettext:${PORTSDIR}/devel/gettext
-RUN_DEPENDS= kdehelp:${PORTSDIR}/x11/kdebase11
-USE_QT= yes
+USE_KDEBASE_VER=1
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib" \
QTDIR="${X11BASE}"
-CONFIGURE_ARGS= --with-qt-includes=${X11BASE}/include/X11/qt \
- --with-qt-libraries=${X11BASE}/lib
pre-patch:
@${PERL} -pi -e "s|-ldl ||g" ${WRKSRC}/kmud/Makefile.in