aboutsummaryrefslogtreecommitdiffstats
path: root/net/krdesktop/Makefile
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2002-06-27 06:14:16 +0800
committerperky <perky@FreeBSD.org>2002-06-27 06:14:16 +0800
commitadc753185dd7ec378a3d4d8b7980ca78f7c5bc48 (patch)
tree7309ad223f3afcc367234ce2c8812d9237282df8 /net/krdesktop/Makefile
parent0659a3f091d9dcc1383e3977d667507d71d8d3c0 (diff)
downloadfreebsd-ports-gnome-adc753185dd7ec378a3d4d8b7980ca78f7c5bc48.tar.gz
freebsd-ports-gnome-adc753185dd7ec378a3d4d8b7980ca78f7c5bc48.tar.zst
freebsd-ports-gnome-adc753185dd7ec378a3d4d8b7980ca78f7c5bc48.zip
Add krdesktop 1.0, kDE Frontend for rdesktop.
PR: 39889 Submitted by: Matt Douhan <matt@athame.co.uk>
Diffstat (limited to 'net/krdesktop/Makefile')
-rw-r--r--net/krdesktop/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/net/krdesktop/Makefile b/net/krdesktop/Makefile
new file mode 100644
index 000000000000..c2edb621fff9
--- /dev/null
+++ b/net/krdesktop/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: krdesktop
+# Date created: 23 June 2002
+# Whom: Matt Douhan <matt@athame.co.uk>
+#
+# $FreeBSD$
+
+PORTNAME= krdesktop
+PORTVERSION= 1.0
+CATEGORIES= net kde
+MASTER_SITES= http://krazykiwi.homeip.net/netwizard/krdesktop/
+DISTNAME= ${PORTNAME:S/kr/KR/}-${PORTVERSION}
+
+MAINTAINER= matt@athame.co.uk
+
+RUN_DEPENDS= rdesktop:${PORTSDIR}/net/rdesktop-devel
+
+USE_KDELIBS_VER=3
+USE_REINPLACE= yes
+NO_WRKSUBDIR= yes
+REINPLACE_ARGS= -E -i.bak
+
+MAKE_ENV= QTDIR=${QT_PREFIX} \
+ KDEDIR=${LOCALBASE} \
+ MOC=${MOC}
+
+CONFIGURE_ARGS= --with-extra-includes=${LOCALBASE}/include \
+ --with-extra-libs=${LOCALBASE}/lib
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,^(CXX|MOC|CXXFLAGS)\+?=,\1?=,g' \
+ -e 's,(\$$\(CXX\) )(\$$\(CXXFLAGS),\1-c \2,g' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>