aboutsummaryrefslogtreecommitdiffstats
path: root/net/libbgpdump
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2014-07-25 11:50:02 +0800
committerpi <pi@FreeBSD.org>2014-07-25 11:50:02 +0800
commitb405d9bde75e5808fe51cfbfa6603d9b37f6b0dd (patch)
treedcd58cec78a27cbcbadf986145dde2257bd829ce /net/libbgpdump
parent25d128297d948d829853b07d6548becab085cd29 (diff)
downloadfreebsd-ports-gnome-b405d9bde75e5808fe51cfbfa6603d9b37f6b0dd.tar.gz
freebsd-ports-gnome-b405d9bde75e5808fe51cfbfa6603d9b37f6b0dd.tar.zst
freebsd-ports-gnome-b405d9bde75e5808fe51cfbfa6603d9b37f6b0dd.zip
net/libbgpdump: add patch from bitbucket
https://bitbucket.org/ripencc/bgpdump/issue/12/binary-garbage-at-the-end-of-output PR: 192091 Submitted by: citrin+pr@citrin.ru Approved by: mjl@luckie.org.nz (maintainer)
Diffstat (limited to 'net/libbgpdump')
-rw-r--r--net/libbgpdump/Makefile2
-rw-r--r--net/libbgpdump/files/patch-bgpdump.c13
2 files changed, 14 insertions, 1 deletions
diff --git a/net/libbgpdump/Makefile b/net/libbgpdump/Makefile
index f09c100ce33b..980982bb59c4 100644
--- a/net/libbgpdump/Makefile
+++ b/net/libbgpdump/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libbgpdump
PORTVERSION= 1.4.99.13
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://www.ris.ripe.net/source/bgpdump/
EXTRACT_SUFX= .tgz
diff --git a/net/libbgpdump/files/patch-bgpdump.c b/net/libbgpdump/files/patch-bgpdump.c
new file mode 100644
index 000000000000..7344261f1223
--- /dev/null
+++ b/net/libbgpdump/files/patch-bgpdump.c
@@ -0,0 +1,13 @@
+--- bgpdump.c.old 2014-07-24 13:02:50.000000000 +0000
++++ bgpdump.c 2014-07-24 13:03:27.000000000 +0000
+@@ -164,10 +164,6 @@
+ exit(1);
+ }
+
+- // more efficient then line buffering
+- char buffer[16000];
+- setbuffer(stdout, buffer, sizeof buffer);
+-
+ BGPDUMP *my_dump = bgpdump_open_dump(argv[0]);
+
+ do {