aboutsummaryrefslogtreecommitdiffstats
path: root/net/libcmis
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-01-23 03:12:56 +0800
committerbapt <bapt@FreeBSD.org>2012-01-23 03:12:56 +0800
commit274b6808834104fa3c0c660453f4e52e3f79d999 (patch)
treec77f632428229f19dad1694a011d5a2133870301 /net/libcmis
parent4a1a04cc59ffc7211f4546f633e9c58d5d2c44cc (diff)
downloadfreebsd-ports-gnome-274b6808834104fa3c0c660453f4e52e3f79d999.tar.gz
freebsd-ports-gnome-274b6808834104fa3c0c660453f4e52e3f79d999.tar.zst
freebsd-ports-gnome-274b6808834104fa3c0c660453f4e52e3f79d999.zip
LibCMIS is a C++ client library for the CMIS interface. This allows C++
applications to connect to any ECM behaving as a CMIS server like Alfresco, Nuxeo for the open source ones. WWW: http://sourceforge.net/projects/libcmis/
Diffstat (limited to 'net/libcmis')
-rw-r--r--net/libcmis/Makefile25
-rw-r--r--net/libcmis/distinfo2
-rw-r--r--net/libcmis/pkg-descr5
-rw-r--r--net/libcmis/pkg-plist12
4 files changed, 44 insertions, 0 deletions
diff --git a/net/libcmis/Makefile b/net/libcmis/Makefile
new file mode 100644
index 000000000000..45c45a0bbf4b
--- /dev/null
+++ b/net/libcmis/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: libcmis
+# Date created: 2012-01-22
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libcmis
+PORTVERSION= 0.1.0
+CATEGORIES= net devel
+MASTER_SITES= SF/${PORTNAME}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Client library for the CMIS interface
+
+LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl
+BUILD_DEPENDS= ${LOCALBASE}/lib/libcppunit.so:${PORTSDIR}/devel/cppunit \
+ ${LOCALBASE}/lib/libboost_regex.a:${PORTSDIR}/devel/boost-libs
+
+GNU_CONFIGURE= yes
+USE_GNOME= libxml2 gnomehack
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/net/libcmis/distinfo b/net/libcmis/distinfo
new file mode 100644
index 000000000000..9e2ba0185a56
--- /dev/null
+++ b/net/libcmis/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libcmis-0.1.0.tar.gz) = 2452f9a746d85a126a9a61d71330f6ecca5449f1ab08f43924d660a143bd7e95
+SIZE (libcmis-0.1.0.tar.gz) = 373429
diff --git a/net/libcmis/pkg-descr b/net/libcmis/pkg-descr
new file mode 100644
index 000000000000..ce87379fd3a9
--- /dev/null
+++ b/net/libcmis/pkg-descr
@@ -0,0 +1,5 @@
+LibCMIS is a C++ client library for the CMIS interface. This allows C++
+applications to connect to any ECM behaving as a CMIS server like Alfresco,
+Nuxeo for the open source ones.
+
+WWW: http://sourceforge.net/projects/libcmis/
diff --git a/net/libcmis/pkg-plist b/net/libcmis/pkg-plist
new file mode 100644
index 000000000000..da372021a205
--- /dev/null
+++ b/net/libcmis/pkg-plist
@@ -0,0 +1,12 @@
+bin/cmis-client
+include/libcmis/cmis-object.hxx
+include/libcmis/document.hxx
+include/libcmis/folder.hxx
+include/libcmis/session-factory.hxx
+include/libcmis/session.hxx
+lib/libcmis-0.2.a
+lib/libcmis-0.2.la
+lib/libcmis-0.2.so
+lib/libcmis-0.2.so.0
+libdata/pkgconfig/libcmis-0.2.pc
+@dirrm include/libcmis