aboutsummaryrefslogtreecommitdiffstats
path: root/net/libfb
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-07-14 22:09:08 +0800
committertijl <tijl@FreeBSD.org>2014-07-14 22:09:08 +0800
commit0a685487dab7197599ffe949cd8eeb38f16079e0 (patch)
tree2123d5e3564b17f4c34233570cd78b85a5657c9a /net/libfb
parentdc2fbce3aeb8750bae1df105663ad3f837f6729f (diff)
downloadfreebsd-ports-gnome-0a685487dab7197599ffe949cd8eeb38f16079e0.tar.gz
freebsd-ports-gnome-0a685487dab7197599ffe949cd8eeb38f16079e0.tar.zst
freebsd-ports-gnome-0a685487dab7197599ffe949cd8eeb38f16079e0.zip
- Add USES=libtool and INSTALL_TARGET=install-strip
- Handle libnet dependency like other ports do
Diffstat (limited to 'net/libfb')
-rw-r--r--net/libfb/Makefile18
-rw-r--r--net/libfb/pkg-plist1
2 files changed, 8 insertions, 11 deletions
diff --git a/net/libfb/Makefile b/net/libfb/Makefile
index c9e52baa4a4a..bbf5b716189d 100644
--- a/net/libfb/Makefile
+++ b/net/libfb/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libfb
PORTVERSION= 2.0.2
+PORTREVISION= 1
CATEGORIES= net net-mgmt
MASTER_SITES= http://support.red-fone.com/downloads/fonulator/
@@ -12,19 +13,16 @@ COMMENT= FoneBRIDGE configuration library
BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
GNU_CONFIGURE= yes
-CPPFLAGS+= ${LIBNET_CPPFLAGS}
-LDFLAGS+= ${LIBNET_LIBS:N-l*}
CONFIGURE_ARGS= --disable-shared
+CPPFLAGS+= ${LIBNET_CPPFLAGS}
+INSTALL_TARGET= install-strip
+USES= libtool
LIBNET_CONFIG= ${LOCALBASE}/bin/libnet11-config
+LIBNET_CPPFLAGS=`${LIBNET_CONFIG} --cflags` `${LIBNET_CONFIG} --defines`
+LIBNET_LIBS= `${LIBNET_CONFIG} --libs`
-.if 0
-# this does not work when LIBNET_CONFIG does not exist prior to building this port
-LIBNET_CPPFLAGS!= ${LIBNET_CONFIG} --cflags --defines
-LIBNET_LIBS!= ${LIBNET_CONFIG} --libs
-.else
-LIBNET_CPPFLAGS= -I${LOCALBASE}/include/libnet11
-LIBNET_LIBS= -L${LOCALBASE}/lib/libnet11
-.endif
+post-patch:
+ @${REINPLACE_CMD} 's,-lnet,${LIBNET_LIBS},' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/net/libfb/pkg-plist b/net/libfb/pkg-plist
index e3ca3bb80ab3..759e55c2849d 100644
--- a/net/libfb/pkg-plist
+++ b/net/libfb/pkg-plist
@@ -3,5 +3,4 @@ include/libfb/fb_context.h
include/libfb/fb_lib.h
include/libfb/sha1.h
lib/libfb.a
-lib/libfb.la
@dirrm include/libfb