aboutsummaryrefslogtreecommitdiffstats
path: root/net/libnet-devel/Makefile
diff options
context:
space:
mode:
authorsmace <smace@FreeBSD.org>2003-01-08 04:50:07 +0800
committersmace <smace@FreeBSD.org>2003-01-08 04:50:07 +0800
commit05235574581b316b26fc88b46558fdec858f8048 (patch)
treed81d80cd5caddb41f7568fa0bd86f64001bd4fbe /net/libnet-devel/Makefile
parent2e97d2f70d0c436ac4983cb27704473a8febf1c6 (diff)
downloadfreebsd-ports-gnome-05235574581b316b26fc88b46558fdec858f8048.tar.gz
freebsd-ports-gnome-05235574581b316b26fc88b46558fdec858f8048.tar.zst
freebsd-ports-gnome-05235574581b316b26fc88b46558fdec858f8048.zip
Add libnet-devel
libnet-devel will maintain libnet-1.1.x. A limited number of ports currently support or will require libnet-1.1.x in the future. The API is not backwards compatible. Unfortunately many ports still require libnet-1.0.x and do not support the new API (and may never support it). libnet-devel will fill the gap until the API change settles out and 1.0.x is fully deprecated.
Diffstat (limited to 'net/libnet-devel/Makefile')
-rw-r--r--net/libnet-devel/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/net/libnet-devel/Makefile b/net/libnet-devel/Makefile
new file mode 100644
index 000000000000..11d71796eb35
--- /dev/null
+++ b/net/libnet-devel/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: libnet11
+# Date created: Jan 7, 2003
+# Whom: smace@freebsd.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= libnet-devel
+PORTVERSION= 1.1.0
+CATEGORIES= net
+MASTER_SITES= http://www.packetfactory.net/libnet/dist/
+DISTNAME= ${PORTNAME:S/-devel$//}-${PORTVERSION}
+
+MAINTAINER= smace@freebsd.org
+
+WRKSRC= ${WRKDIR}/Libnet-latest
+
+USE_AUTOMAKE= yes
+USE_AUTOCONF= yes
+
+MAN3= libnet.3
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/libnet-config ${PREFIX}/bin
+
+.include <bsd.port.mk>