aboutsummaryrefslogtreecommitdiffstats
path: root/net/libnet10
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-06-12 04:08:35 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-06-12 04:08:35 +0800
commit14bf7693504b5cb20e91d99a9dc06a05622450d9 (patch)
treedf5fc5badf346527ea30c6e44398c296510639ff /net/libnet10
parentf0a96d0f593836db4776121d8ea201587afdb35e (diff)
downloadfreebsd-ports-gnome-14bf7693504b5cb20e91d99a9dc06a05622450d9.tar.gz
freebsd-ports-gnome-14bf7693504b5cb20e91d99a9dc06a05622450d9.tar.zst
freebsd-ports-gnome-14bf7693504b5cb20e91d99a9dc06a05622450d9.zip
Library net/libnet10 defines structures for contents of network packets.
Fields of the packets have fixed size according to the respective protocol definitions, but the library uses type u_long for some of the 32bit fields. This is a problem on amd64 architecture, where type long has 64 bits. On amd64, libnet creates packets with bad contents. PR: ports/122571 Submitted by: Martin Beran <mb@tns.cz>
Diffstat (limited to 'net/libnet10')
-rw-r--r--net/libnet10/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/net/libnet10/Makefile b/net/libnet10/Makefile
index cc82ce5ae141..a60045f0ce88 100644
--- a/net/libnet10/Makefile
+++ b/net/libnet10/Makefile
@@ -23,6 +23,13 @@ WRKSRC= ${WRKDIR}/Libnet-${PORTVERSION}
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
MAN3= libnet${PKGNAMESUFFIX}.3
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+post-patch:
+ find ${WRKDIR} -name '*.[hc]' | xargs ${REINPLACE_CMD} -e 's/long/int/g'
+.endif
+
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/libnet.3 \
${MANPREFIX}/man/man3/libnet${PKGNAMESUFFIX}.3
@@ -39,4 +46,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>