aboutsummaryrefslogtreecommitdiffstats
path: root/net/libnids
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-07-14 22:46:55 +0800
committertijl <tijl@FreeBSD.org>2014-07-14 22:46:55 +0800
commita2266fbacfe9ae2929a33f474f6068049674a84f (patch)
tree033218273dcd0c75a60f7e734a959b63faca12e9 /net/libnids
parent3562b18da56264fd5f2c9ddcae43965cecd563a3 (diff)
downloadfreebsd-ports-gnome-a2266fbacfe9ae2929a33f474f6068049674a84f.tar.gz
freebsd-ports-gnome-a2266fbacfe9ae2929a33f474f6068049674a84f.tar.zst
freebsd-ports-gnome-a2266fbacfe9ae2929a33f474f6068049674a84f.zip
Remove the option to depend on net/libnet10 and depend on net/libnet
unconditionally. Since this is the last consumer of net/libnet10 this allows marking that port deprecated.
Diffstat (limited to 'net/libnids')
-rw-r--r--net/libnids/Makefile34
1 files changed, 7 insertions, 27 deletions
diff --git a/net/libnids/Makefile b/net/libnids/Makefile
index ad3162467ae7..31aaa95ed67e 100644
--- a/net/libnids/Makefile
+++ b/net/libnids/Makefile
@@ -3,56 +3,36 @@
PORTNAME= libnids
PORTVERSION= 1.24
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net security
MASTER_SITES= SF
MAINTAINER= wxs@FreeBSD.org
COMMENT?= Network monitoring library with TCP/IP reassembly
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
+
LICENSE= GPLv2
CONFLICTS?= libnids-libnet11-[0-9]*
-OPTIONS_DEFINE= LIBNET10 LIBNET11 GLIB2
-LIBNET10_DESC= Use libnet 1.0.x
-LIBNET11_DESC= Use libnet 1.1.x
+OPTIONS_DEFINE= GLIB2
+OPTIONS_DEFAULT=GLIB2
GLIB2_DESC= Use GLIB2 for multiprocessing support
OPTIONS_SUB= yes
-.if defined(WITH_LIBNET11)
-OPTIONS_DEFAULT= LIBNET11 GLIB2
-.else
-OPTIONS_DEFAULT= LIBNET10 GLIB2
-.endif
GLIB2_USE= gnome=glib20
GLIB2_CONFIGURE_ENABLE= libglib
-WANT_GNOME= yes
USES= pkgconfig
GNU_CONFIGURE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MLIBNET10}
-LIBNET_VERSION= 10
-BUILD_DEPENDS+= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet${LIBNET_VERSION}
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet${LIBNET_VERSION}-config
-LIBNET_LIB= "-L${LOCALBASE}/include/libnet${LIBNET_VERSION} \
- ${LOCALBASE}/lib/libnet${LIBNET_VERSION}/libnet.a"
-.elif ${PORT_OPTIONS:MLIBNET11}
-LIBNET_VERSION= 11
-BUILD_DEPENDS+= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet${LIBNET_VERSION}-config
-LIBNET_LIB= "`${LIBNET_CONFIG} --libs`"
-.else
-CONFIGURE_ARGS+= --disable-libnet
-.endif
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
post-patch:
@${REINPLACE_CMD} -Ee \
's|(LNET_CFLAGS=).*|\1"`${LIBNET_CONFIG} --defines` `${LIBNET_CONFIG} --cflags`"|; \
- s|(LNETLIB=).*|\1${LIBNET_LIB}|' \
+ s|(LNETLIB=).*|\1"`${LIBNET_CONFIG} --libs`"|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
do-install: