aboutsummaryrefslogtreecommitdiffstats
path: root/net/libnids
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-01-31 22:09:55 +0800
committerpav <pav@FreeBSD.org>2007-01-31 22:09:55 +0800
commitccd12ccd577604add511aad4ea4e71c32b3e2f06 (patch)
tree25b833c135dd7f2323045f819dc7121e621103fc /net/libnids
parente2f15954f8960a944e8d5b2c28982257d8c6e91f (diff)
downloadfreebsd-ports-gnome-ccd12ccd577604add511aad4ea4e71c32b3e2f06.tar.gz
freebsd-ports-gnome-ccd12ccd577604add511aad4ea4e71c32b3e2f06.tar.zst
freebsd-ports-gnome-ccd12ccd577604add511aad4ea4e71c32b3e2f06.zip
- Patch net/libnet* to versioned libraries and header files, so they can
coexist PR: ports/103861 Submitted by: alepulver Tested by: pointyhat With hat: portmgr
Diffstat (limited to 'net/libnids')
-rw-r--r--net/libnids/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/net/libnids/Makefile b/net/libnids/Makefile
index 76103a1eb6e7..7b63389a8c1a 100644
--- a/net/libnids/Makefile
+++ b/net/libnids/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libnids
PORTVERSION= 1.21
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,19 +20,23 @@ OPTIONS= LIBNET "Include code requiring libnet" ON \
GLIB2 "Use GLIB2 for multiprocessing support" ON
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
MAKE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+MAN3= libnids.3
+
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_LIBNET)
.if !defined(WITHOUT_LIBNET10)
-BUILD_DEPENDS+= libnet*<=1.1.0,1:${PORTSDIR}/net/libnet10
+BUILD_DEPENDS+= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
.else
-BUILD_DEPENDS+= libnet*>=1.1.2,1:${PORTSDIR}/net/libnet
+BUILD_DEPENDS+= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
.endif
.else
CONFIGURE_ARGS+= --disable-libnet
@@ -44,7 +48,11 @@ LIB_DEPENDS+= glib-2.0:${PORTSDIR}/devel/glib20
CONFIGURE_ARGS+= --disable-libglib
.endif
-MAN3= libnids.3
+post-patch:
+ @${REINPLACE_CMD} -Ee \
+ 's|(LNET_CFLAGS=).*|\1"`${LIBNET_CONFIG} --defines` `${LIBNET_CONFIG} --cflags`"|; \
+ s|(LNETLIB=).*|\1"`${LIBNET_CONFIG} --libs`"|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
do-install:
${INSTALL_DATA} ${WRKSRC}/src/nids.h ${PREFIX}/include