aboutsummaryrefslogtreecommitdiffstats
path: root/net/libtorrent
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2005-03-20 22:38:39 +0800
committerflz <flz@FreeBSD.org>2005-03-20 22:38:39 +0800
commit149e86f1f3cd7799f26b9373616f2745b9a3ba30 (patch)
tree1e224b21ccde9a12e1ac42f5f9722715a5919a74 /net/libtorrent
parentf4f98ad61580b698efe5972837abf13268421d30 (diff)
downloadfreebsd-ports-gnome-149e86f1f3cd7799f26b9373616f2745b9a3ba30.tar.gz
freebsd-ports-gnome-149e86f1f3cd7799f26b9373616f2745b9a3ba30.tar.zst
freebsd-ports-gnome-149e86f1f3cd7799f26b9373616f2745b9a3ba30.zip
- Update to 0.5.4.
Diffstat (limited to 'net/libtorrent')
-rw-r--r--net/libtorrent/Makefile5
-rw-r--r--net/libtorrent/distinfo4
-rw-r--r--net/libtorrent/files/patch-client::rtorrent.cc14
-rw-r--r--net/libtorrent/files/patch-src::data::file.cc13
-rw-r--r--net/libtorrent/files/patch-src::torrent::torrent.h11
-rw-r--r--net/libtorrent/pkg-plist1
6 files changed, 5 insertions, 43 deletions
diff --git a/net/libtorrent/Makefile b/net/libtorrent/Makefile
index 71a030f6be85..ed55d2b3eaf7 100644
--- a/net/libtorrent/Makefile
+++ b/net/libtorrent/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libtorrent
-PORTVERSION= 0.5.0
-PORTREVISION= 2
+PORTVERSION= 0.5.4
CATEGORIES= net
MASTER_SITES= http://libtorrent.rakshasa.no/downloads/
@@ -16,7 +15,7 @@ COMMENT= BitTorrent Library written in C++
LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20
-USE_GCC= 3.3+
+USE_GCC= 3.4
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
USE_INC_LIBTOOL_VER= 13
diff --git a/net/libtorrent/distinfo b/net/libtorrent/distinfo
index f36d2a4eed05..f41948a9d16a 100644
--- a/net/libtorrent/distinfo
+++ b/net/libtorrent/distinfo
@@ -1,2 +1,2 @@
-MD5 (libtorrent-0.5.0.tar.gz) = c146ba6129d8f0b0b155186d35236e1e
-SIZE (libtorrent-0.5.0.tar.gz) = 301239
+MD5 (libtorrent-0.5.4.tar.gz) = 77d1c39f2c17bddc572ae426b53e8367
+SIZE (libtorrent-0.5.4.tar.gz) = 294733
diff --git a/net/libtorrent/files/patch-client::rtorrent.cc b/net/libtorrent/files/patch-client::rtorrent.cc
deleted file mode 100644
index c4f107aa91db..000000000000
--- a/net/libtorrent/files/patch-client::rtorrent.cc
+++ /dev/null
@@ -1,14 +0,0 @@
---- client/rtorrent.cc.old Fri Jan 7 15:04:15 2005
-+++ client/rtorrent.cc Fri Jan 7 15:04:57 2005
-@@ -19,9 +19,9 @@
- #include "curl_get.h"
-
- // Uncomment this if your system doesn't have execinfo.h
--#define USE_EXECINFO
-+//#define USE_EXECINFO
-
--#ifdef USE_EXECINFO
-+#ifdef USE_EXECINFO
- #include <execinfo.h>
- #endif
-
diff --git a/net/libtorrent/files/patch-src::data::file.cc b/net/libtorrent/files/patch-src::data::file.cc
deleted file mode 100644
index e0b3abd2b8fa..000000000000
--- a/net/libtorrent/files/patch-src::data::file.cc
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/data/file.cc.old Fri Jan 7 14:35:43 2005
-+++ src/data/file.cc Fri Jan 7 14:36:35 2005
-@@ -19,8 +19,9 @@
- (flags & in && flags & out ? O_RDWR :
- (flags & in ? O_RDONLY : 0) |
- (flags & out ? O_WRONLY : 0)) |
--
-+#if defined(Linux)
- (flags & largefile ? O_LARGEFILE : 0) |
-+#endif
- (flags & create ? O_CREAT : 0) |
- (flags & truncate ? O_TRUNC : 0) |
- (flags & nonblock ? O_NONBLOCK : 0),
diff --git a/net/libtorrent/files/patch-src::torrent::torrent.h b/net/libtorrent/files/patch-src::torrent::torrent.h
deleted file mode 100644
index bb7f00317f7e..000000000000
--- a/net/libtorrent/files/patch-src::torrent::torrent.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/torrent/torrent.h.old Fri Jan 7 22:34:09 2005
-+++ src/torrent/torrent.h Fri Jan 7 22:51:03 2005
-@@ -4,6 +4,8 @@
- #include <list>
- #include <torrent/common.h>
- #include <torrent/download.h>
-+#include <sys/types.h>
-+#include <sys/select.h>
-
- namespace torrent {
-
diff --git a/net/libtorrent/pkg-plist b/net/libtorrent/pkg-plist
index 5703eca87e2e..63262e4b9fca 100644
--- a/net/libtorrent/pkg-plist
+++ b/net/libtorrent/pkg-plist
@@ -6,6 +6,7 @@ include/torrent/entry.h
include/torrent/http.h
include/torrent/peer.h
include/torrent/torrent.h
+include/torrent/tracker.h
lib/libtorrent.so
lib/libtorrent.so.2
libdata/pkgconfig/libtorrent.pc