aboutsummaryrefslogtreecommitdiffstats
path: root/net/licq/files
diff options
context:
space:
mode:
authorgreen <green@FreeBSD.org>2001-04-11 04:09:53 +0800
committergreen <green@FreeBSD.org>2001-04-11 04:09:53 +0800
commitf07a9e4fac742090e01c362e04f7b7aa425fbe5a (patch)
tree1223c579f5181bc78af966be4a3878e9964337f0 /net/licq/files
parenta900bc4cbb4dc2b75c17e20b86a287e7946a110e (diff)
downloadfreebsd-ports-gnome-f07a9e4fac742090e01c362e04f7b7aa425fbe5a.tar.gz
freebsd-ports-gnome-f07a9e4fac742090e01c362e04f7b7aa425fbe5a.tar.zst
freebsd-ports-gnome-f07a9e4fac742090e01c362e04f7b7aa425fbe5a.zip
Convert the monolithic Licq port into an licq-base port and satellite
ports for different plugins. Commit the first of the plugins, qt-gui, as that has in the past been part of the normal licq port. The rest are coming after I've tried them out. I'd like to thank Jeremy Norris greatly for doing this work :) Submitted by: Jeremy Norris <ishmael27@home.com>
Diffstat (limited to 'net/licq/files')
-rw-r--r--net/licq/files/patch-aa11
-rw-r--r--net/licq/files/patch-ab31
-rw-r--r--net/licq/files/patch-ac11
-rw-r--r--net/licq/files/patch-ad48
4 files changed, 0 insertions, 101 deletions
diff --git a/net/licq/files/patch-aa b/net/licq/files/patch-aa
deleted file mode 100644
index ebda08f5a29f..000000000000
--- a/net/licq/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugins/qt-gui-1.0.3/configure.in.orig Wed Aug 9 14:07:59 2000
-+++ plugins/qt-gui-1.0.3/configure.in Wed Aug 9 14:15:46 2000
-@@ -51,8 +51,6 @@
- LICQ_CHECK_X11HEADERS
-
- XSS_LIBS="no"
--AC_CHECK_X_LIB(Xext, XScreenSaverRegister,[XSS_LIBS=""],[], [-lX11 -lXext -lm])
--AC_CHECK_X_LIB(Xss, XScreenSaverRegister,[XSS_LIBS="-lXss"],[],[-lX11 -lXext -lm])
- if test \! "$XSS_LIBS" = "no"; then
- AC_CHECK_X_HEADER(X11/extensions/scrnsaver.h,[AC_DEFINE(USE_SCRNSAVER)])
- else
diff --git a/net/licq/files/patch-ab b/net/licq/files/patch-ab
deleted file mode 100644
index f3a6d5b88496..000000000000
--- a/net/licq/files/patch-ab
+++ /dev/null
@@ -1,31 +0,0 @@
---- plugins/qt-gui-1.0.3/acinclude.m4.in.orig Sun Jun 18 06:20:57 2000
-+++ plugins/qt-gui-1.0.3/acinclude.m4.in Mon Jul 24 03:09:28 2000
-@@ -48,7 +48,7 @@
- fi
-
- for qt_dir in $qt_library_dirs; do
-- for qt_check_lib in $qt_dir/libqt.so.2; do
-+ for qt_check_lib in $qt_dir/libqt2.so.3; do
- if test -r $qt_check_lib; then
- ac_qt_libraries=$qt_dir
- break 2
-@@ -68,7 +68,7 @@
- else
- have_qt_lib="yes"
- dnl Check if we have the right lib
-- output=`eval "strings $ac_cv_lib_qtlib/libqt.so | grep -l QCString"`
-+ output=`eval "strings $ac_cv_lib_qtlib/libqt2.so | grep -l QCString"`
- if test -z "$output"; then
- AC_MSG_ERROR([
- The Qt lib directory "$ac_cv_lib_qtlib"
-@@ -185,8 +185,8 @@
-
- AC_PATH_PROG(
- MOC,
-- moc,
-- $QTDIR/bin/moc,
-+ moc2,
-+ $QTDIR/bin/moc2,
- $QTDIR/bin:/usr/lib/qt2/bin:/usr/bin:/usr/X11R6/bin:/usr/lib/qt/bin:/usr/local/qt/bin:$PATH
- )
- else
diff --git a/net/licq/files/patch-ac b/net/licq/files/patch-ac
deleted file mode 100644
index 908462c6faf7..000000000000
--- a/net/licq/files/patch-ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugins/qt-gui-1.0.3/src/Makefile.in.orig Tue Jul 11 18:54:27 2000
-+++ plugins/qt-gui-1.0.3/src/Makefile.in Mon Jul 24 03:12:25 2000
-@@ -119,7 +119,7 @@
-
- licq_qt_gui_la_LDFLAGS = $(X_LIBS) $(QT_LDFLAGS) $(KDE_LDFLAGS) -module -avoid-version -rpath $(libdir) -R$(QT_LIBDIR)
-
--licq_qt_gui_la_LIBADD = $(KDE_LIBS) -lqt $(X_PRE_LIBS) -lX11 -lXext $(XSS_LIBS) $(X_EXTRA_LIBS)
-+licq_qt_gui_la_LIBADD = $(KDE_LIBS) -lqt2 $(X_PRE_LIBS) -lX11 -lXext $(XSS_LIBS) $(X_EXTRA_LIBS)
-
-
- #>- METASOURCES = AUTO
diff --git a/net/licq/files/patch-ad b/net/licq/files/patch-ad
deleted file mode 100644
index 7bf734c85ce6..000000000000
--- a/net/licq/files/patch-ad
+++ /dev/null
@@ -1,48 +0,0 @@
---- src/socket.cpp.orig Tue Jul 4 20:51:50 2000
-+++ src/socket.cpp Mon Jul 24 03:32:56 2000
-@@ -12,6 +12,7 @@
- #include <netdb.h>
- #include <fcntl.h>
- #include <unistd.h>
-+#include <osreldate.h>
-
- #ifndef MSG_DONTWAIT
- #define MSG_DONTWAIT 0
-@@ -288,7 +289,12 @@
- bool INetSocket::SetLocalAddress(bool bIp)
- {
- // Setup the local structure
-+
-+#if __FreeBSD_version < 400013
-+ int sizeofSockaddr = sizeof(struct sockaddr_in);
-+#else
- socklen_t sizeofSockaddr = sizeof(struct sockaddr_in);
-+#endif
- if (getsockname(m_nDescriptor, (struct sockaddr *)&m_sLocalAddr, &sizeofSockaddr) < 0)
- {
- m_nErrorType = SOCK_ERROR_errno;
-@@ -372,7 +378,11 @@
- m_sRemoteAddr.sin_family = AF_INET;
-
- // if connect fails then call CloseConnection to clean up before returning
-+#if __FreeBSD_version < 400013
-+ int sizeofSockaddr = sizeof(struct sockaddr);
-+#else
- socklen_t sizeofSockaddr = sizeof(struct sockaddr);
-+#endif
- if (connect(m_nDescriptor, (struct sockaddr *)&m_sRemoteAddr, sizeofSockaddr) < 0)
- {
- // errno has been set
-@@ -504,7 +514,11 @@
- *---------------------------------------------------------------------------*/
- void TCPSocket::RecvConnection(TCPSocket &newSocket)
- {
-- socklen_t sizeofSockaddr = sizeof(struct sockaddr_in);
-+#if __FreeBSD_version < 400013
-+ int sizeofSockaddr = sizeof(struct sockaddr_in);
-+#else
-+ socklen_t sizeofSockaddr = sizeof(struct sockaddr_in);
-+#endif
- newSocket.m_nDescriptor = accept(m_nDescriptor, (struct sockaddr *)&newSocket.m_sRemoteAddr, &sizeofSockaddr);
- newSocket.SetLocalAddress();
- }