aboutsummaryrefslogtreecommitdiffstats
path: root/net/licq
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-08-28 23:38:18 +0800
committerdinoex <dinoex@FreeBSD.org>2003-08-28 23:38:18 +0800
commit162b1e72de32c194510910cb119f0b756e0eedca (patch)
tree70561ba0aab5be91ede6b42af1261ecf9614f120 /net/licq
parent932eb2d5750a214e130cd9c6ce4d90413d8326c9 (diff)
downloadfreebsd-ports-gnome-162b1e72de32c194510910cb119f0b756e0eedca.tar.gz
freebsd-ports-gnome-162b1e72de32c194510910cb119f0b756e0eedca.tar.zst
freebsd-ports-gnome-162b1e72de32c194510910cb119f0b756e0eedca.zip
- use hook for bsd.openssl.mk
Diffstat (limited to 'net/licq')
-rw-r--r--net/licq/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/net/licq/Makefile b/net/licq/Makefile
index 0e113d1d375b..aecde4ae98f7 100644
--- a/net/licq/Makefile
+++ b/net/licq/Makefile
@@ -31,6 +31,12 @@ CONFIGURE_ARGS+=--with-socks5-inc=${LOCALBASE}/include
CONFIGURE_ENV+= LDFLAGS=-L${LOCALBASE}/lib
.endif
+.if !defined(WITHOUT_OPENSSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+=--with-openssl-inc=${OPENSSLINC}
+CONFIGURE_ARGS+=--with-openssl-lib=${OPENSSLLIB}
+.endif
+
pre-configure:
@${MV} ${WRKSRC}/src/licq.conf.h ${WRKSRC}/src/licq.conf.h.sed
${SED} -e "s=/usr/share/licq=${PREFIX}/share/licq=" \
@@ -45,9 +51,5 @@ post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
-CONFIGURE_ARGS+=--with-openssl-inc=${OPENSSLINC}
-CONFIGURE_ARGS+=--with-openssl-lib=${OPENSSLLIB}
-
.include "${LICQ_PORT}/Makefile.inc"
.include <bsd.port.post.mk>